Client NEVER removes SPAM. EVER.

I get 30-50 idiotic SPAM/day, mostly the same over and over, highlight them, choose Junk - Blacklist Sender or Domain, even created rules to delete them and every day there they are.  If I use my Charter Spectrum online email it blocks them all, but not EM Client.  IS there any fix for this?  I cannot be the only one with this problem.

eM Client cannot actually detect spam the same way your server does. If you use the Rule method, it will only move messages that are an exact match to what you have specified. Check that the address or domain in the Rule is the same as that in those it is not moving. If there is any difference, it will not be moved.

Obviously choosing to blacklist the domain is more effective, but the trick the spammers use is ever changing domains or sub domains. Then the Rule you create will not work.

Best option is enable spam filtering on your server.

Thanks, Gary.  I do have SPAM filtering which is why I don’t see most of these when I use the Charter website.  What I don’t get is why they are filtered there but still get through to other clients.  Do you know this - when I create a rule, do I have to go and RUN the rule every time or is it running in the background?  I cannot tell on this client because the keyword rules still aren’t filtering SPAM 

eM Client is not compatible with Charter servers, so that may be the cause.

Rules in eM Client run automatically and are only applied to new messages as they arrive in your Inbox. They will not apply to existing messages or messages in other folders. If you have a filter on your server that moves messages to a folder, Rules will not apply to them either. If you create a new Rule and want to apply it to existing messages, or folders, you will need to run it manually.

When creating Rules for keywords, using the with words found in the header option might be more successful. Search this forum for the phrase in bold; I have given many examples.