Class not registered error message

I have a question, I keep getting an “class not registered” when clicking on a link in an email. Any ideas on what the problem is and how I can fix it?

Hi, do you have latest version of IE?


Hi, Yes, I have the newest version. Uninstalled it, cleaned the folders and registry, reinstalled it, still same error.

I just solved my own problem. I am using windows 8.1, and before the problem started, my default browser was Firefox. I changed browsers to Pale Moon, which is a 64bit variant of Firefox. I set Pale Moon as my default browser. That is when my errors in em client begin. I started getting the class not registered error because em client didn’t recognize Pale Moon as the default browser. So when clicking on links, em client didn’t see any browser and returned the class not registered error. Once I reinstalled Firefox, and set it as default, the error went away, and links worked again. What tipped me to the solution / problem was that other programs I installed had the same problem, links didn’t work when Pale Moon was set as default browser.

Thank you for this explanation.


Thank you for emclient