Change of email settings

My service provider TalkTalk has said I need to change my email settings as my current settings are insecure and after 8th October I will not be able to access emails.

I have to change the incoming port to 993 (it is currently 143 which you set automatically). I have tried to change it in settings but it does not work.

Can you please help me with this as I will no longer be able to use your program for my emails.

yhegarty@talktalk.net

When you change the port to 993, you also need to change the security policy. Set it to Use SSL/TLS on special port (legacy) then click on Save & Close.

Can you post your account settings (without personal info) and what is not working?

Current settings are Incoming Server Port 143 and Outgoing Server Port 587. TalkTalk require me to change Incoming Port to 993. Outgoing Port is OK. When I make the change I can no longer send or receive emails so I have to return to the old setting. The old setting will work until 8th October when TalkTalk say it will no longer work.

What do you have set for the “Security Policy”?

Thank you so much. I changed on my phone first (Android) and all worked perfectly. Then went to eMClient on laptop and made changes to security policy as you advised. Then I thought perhaps I needed to change Outgoing Security Type so changed it to same setting that you said but then email didn’t send. So I changed it back to Force SSL/TLS which is what it was on before and it seems to be fine so hopefully all will now be OK. The instructions from TalkTalk doesn’t give these security options. It states that incoming should be SSL/TLS or SSL (for Android) and SSL/TLS for Windows. On Outgoing states TLS for Android and STARTTLS for Windows which doesn’t appear as an option at all.

Now changed to SSL/TLS on Special Port (Legacy) for incoming. Force usage of SSL/TLS for outgoing. Seems to work.

That is what my settings are after my ISP sent a similar notice to me in July… so you should be fine…

Thanks I do hope so. After weeks of stressing and endless conversations with TalkTalk it seems one simple answer was all rhat was required. Pity TalkTalk don’t have rgis knowledge!