Change default email address for calendar invites (Google calendar)

How do I change the default sending address for calendar invites? In the included a screengrab you can see that you change the sending account in he bottom left corner. However mine is always set to the account attached to my Google account and not my corporate email. It would be nice to be able to set as my corporate mail per default… How do I do that?

We are using em-client (ver. 6.0.20617.0)  in our small office of 40 people. We host our email with a local provider and use IMAP. We host our individual calendars on our private Google accounts where each of us has set up a work calendar that we share with relevant coworkers…

Hi Mikkel, not completely sure what you have in mind. eM client automatically assigns a new calendar event with the account in which folder you’re currently located in.
Some options in eM Client will create a new calendar event in your default account, and to setup a default account go to Tools > Accounts > Your account, and click on the “Make default” button.

Hope this helps,

The account i want as my default is already my default…

Can you please specify what the issue is then? Where are you located:focused to in the application when you select to create a new event and when the “wrong” account is selected?

Thank you,