Certificate Problem

Since a few days a get an certificate error, about once an hour.
I don’t use mail encryption. The error is probaly generated from TLS.
I tryed out all the buttons on the lower edge of the error message:
Ticked “Don’t ask me again” and “connect” let the message disappear but the coonction fails this way (red markings right of the Account Name). Pressing “Refresh” in the menue bar works well, communication is OK without any Error - until one hour later - the same game again.
I only have Outlook Accounts in emclient.
The same error is on my two machines, Notebook and PC
As I’m not familiar with Certificate handling in Win 10 and emclient, I would be happy to get some tips.

Windows 10 Pro 19041.508, emclient 8.0.3385, payed version, 2 users


Outlook Certificate

Used brute force method
Deinstalled emclient
Use Thunderbird now
All OK

pitakon, not Swiss by chance, are you?

This is a serious issue, which I have been getting also.

But, I think it’s actually Microsoft’s fault, from the technical aspects of it, and indeed it looks like the problem has now gone away.

If it comes back, I’ll try telling them on my pro support channel. But indeed I think it’s really Microsoft who has had to fix their mistake - a mismatched certificate on their server, from having looked at it…


1 Like

Yes, I also thought it looked like a Microsoft issue. I had this once with another email provider, and after I contacted them, they fixed it.

This is still an issue and not MS specific.

The problem seems to be that emClient does not check certificate alternative names.
It definitely should check alternative names which are also valid for a certificate.

@emclient Team, please check on this.

I also opened a support request (#127719) for this since we are reselling emClient and this is a more serious issue for many of our customers!