CC/BCC Not Shown in New Mail, Unless You Remember to Make Extra Click

When composing a new email message, if:

  • You have Settings -> Mail -> Compose -> “Show CC and BCC fields when composing” UNchecked

  • And you click the “To” button on the New Message

  • And highlight a Contact in the Select Contact box

  • And click the “CC:” button

  • And click the “OK” button

…then back in the New Mail message form, that CC (or CCs, or BCCs) will not be shown, unless you then click the “Add Cc & Bcc” button.

I’d consider that a bug, because it looks as if you haven’t added any CC recipients (especially if you also added some “To” recipients). My suggestion is that if you add a CC or a BCC in the Select Contact box, then when you return to the New Mail form (by pressing “OK”), that form should then automatically show the CC and BCC fields, as if you had clicked the “Add Cc & Bcc” button. (And, of course, that button’s text should also be changed to “Add CC & BCC”.)

This report is relevant to version 5.0.17595.

OK, we will consider it.

Thank you.

I’d also like to reiterate my request that you treat CCs and BCCs separately. I realize that some people may feel otherwise – and this is why program preferences exist – but I NEVER use BCC; thus, any BCC field just takes up screen space for me.

Thus, I’d like to see two buttons in the New Mail form (“Add CC” and “Add BCC”) and two settings (“Show CC field when composing” and “Show BCC field when composing”). That is, if future coding gets done in this area, I’d appreciate it if the program acted as if an “Add CC” button were pressed if CCs were added in the Select Contact box, and as if an “Add BCC” button were pressed if BCCs were added in the Select Contact box (assuming each of these were UNchecked in the Settings preferences).