Card/CalDAV Sync via HTTPS

I am not able to use Card- / CalDav with HTTPS Connection. It just doesnt sync. When I switch to HTTP it works. But I am able to “visit” the encrypted site with my browser and I am also able to sync via internal IP address but thats not the thing I want. Any suggestions? I am using a HTTPS Certificate from SSLCert. Greetings :slight_smile:

Hi, can you please go to Tools > Settings > Advanced and turn on CalDav / CardDAV logging for the problematic account, save the settings and restart the application.
In the left sidebar right click your Calendar folder and select Properties > Repair and click on the repair button.

If that doesn’t solve the issue, try to replicate the issue, when you see it doesn’t sync, go back to the advanced settings window and click on “Send Logs”, please send the logs to mcgregor@emclient.com and please include a reference link to this forum topic.

Thank you,
Paul.

Hey Paul,
thanks for the reply!

If I add the calendar as HTTPS, then I even cant click on “repair” because the calendar does not show up.
When I add it without HTTPS and then change the server address to HTTPS, clicking the calendar “repair” doesnt do anything.

I just sent you the logs! :slight_smile:

Greetings

Hi Robin, could you please go back to the Advanced settings window and check the Network Communications logging instead of CalDav / CardDav.
Same instructions as before, when the issue occurs, send the logs to mcgregor@emclient.com

Thank you, unfortunately the issue is not visible in the received logs…
What CalDav/CardDav server are you using?

Thank you,
Paul.