Can't upgrade eM Client 8 to 9, or even uninstal eM Client 8

Long story short - can’t upgrade or uninstall eM Client 8, the uninstaller is broken, and uninstall is required during the upgrade process.

I got a notification about eM Client 9 release and wanted to give it a try, downloaded the installer and started upgrading it, but got the error saying I need the previous installer to uninstall the previous version of the eM Client.

Obviously not ideal, but after some searching on the internet, I’ve managed to download the old installer to be able to uninstall the eM Client, but got the error that says:


Looks like it says it needs 8.2.1175, but doesn’t want 8.2.1175 downloaded from the internet, so tried to run the installer by itself, and got error that said I have a newer version installed.

Checked the Add/Remove Programs for the installed version… it says I have 8.2.1473.0 installed, not 8.2.1175.

Ok, no idea why the uninstaller doesn’t recognize the version that is currently installed, but next I’ve located 8.2.1473.0, downloaded it, and tried running it. It started the upgrade and asked me for a path to 8.2.1175 installer file so it can uninstall the previous version…

LOL, this acts as if it wants to do the upgrade and uninstall the previous version, but obviously uninstalling also doesn’t work… But wait, what if both of those numbers are wrong? Let’s check the “About” window in eM Client… It says 8.2.1659.0

Yeah, a different version is displayed there. This is not fun anymore, not sure if it’s something about buggy installer code, broken build server, or whatever else, but it’s one big mess.

Needless to say, I have decided to give it another try, hunted down the installer for this version, and tried running it again, but during the installation process it required 8.2.1175 again (and didn’t work with it).

Looks like there are numerous things broken:

  • to upgrade or uninstall the eM Client I need the original installer file that was stored in Temp folder (obviously it’s not there anymore), not to mention that uninstall process should not require any files that are not in the program directory
  • there are no links to previous installers on the eM Client website (I had to look for Choco install scripts and then change the download URL to get the correct file downloaded from the server)
  • even when the correct installer file is selected, it will not uninstall
  • the versions demanded by the uninstaller, displayed in Add/Remove Programs and in About window are messed up

Also I’ve managed to take screenshots of everything, added them to my post, but when clicking “create topic” got “sorry, new users can embed only one file”…

Just if someone is curious or needs those installers, here is the original link from Choco, you can modify it by changing the version part and get the installer:

That is a Windows install / uninstall issue and not eM Client.

Running the Microsoft Troubleshooting program below up to Windows 10 normally fixes that.

Failing that you have more of a Registry issue and need to contact Microsoft for further help.

Fix problems that block programs from being installed or removed (

there are no links to previous installers on the eM Client website

Release History All versions for PC up to now latest V9 | eM Client

Yes - there is a list of some releases, but 8.2.1175 that the installer complained about isn’t there, the same goes for 8.2.1659.

That didn’t fix the version mismatch problem, but fixed it enough to uninstall and install the new version. :slight_smile:

1 Like