Can't uninstall, reinstall, upgrade or open eM Client

My Windows 8.1 box froze a couple of weeks ago and required a hard reboot. Ever since, eM Client won’t start. I tried uninstalling and reinstalling but nothing works. I get the same message every time:

I can’t install v.6b.2, can’t reinstall 5.0, can’t install any of my older versions.

I tried removing all registry entries relating to emClient but still get the same error. I can’t do anything. Is there anywhere where the setup program might leave a log file that I can try to diagnose the problem myself?


please unninstall eM Client and delete database folder manually, then use this link

for 5th version…


Hi Jan,

I can’t uninstall because I get that error (from the linked screenshot) every time. I can’t install a new version (5.0 or 6.0 beta 2) because I get the same error. I can’t repair an existing version because I get the same error.

I manually deleted the eM Client folder in Program Files (x86). I manually deleted registry entries relating to eM Client. User directories remain, so we don’t lose our email history, but I don’t see how they would affect the install process.

Basically I’m stuck in some indeterminate state. The error message (from the screenshot) isn’t very descriptive so I can’t figure out which part of the install process is failing and how I could manually resolve it.

I am comfortable with the command line and registry editing and have good technical knowledge but there is no clue where to start.

I know if I reinstalled Windows and started with a clean slate I could get it to work, but that’s a dramatic step just for a single email program.

No other applications are having problems, just eM Client.

Then could you try to install another software from .msi file? If it will not fail then I will write you another steps.


Hi Jan,

I had LibreOffice 4.0.5, just upgraded to 4.0.6 from .msi successfully.

Then you can try unattended (silent) installation, back in the days in Win Vista and my old laptop I was able to install even not compatible drivers for hardware using /q command in CMD.


Fails. I created a logfile that I can email to you if you give me an email address.

I ran:

msiexec /i eMClient_6_setup.msi /jm /L*v logfile.txt

i.e. installing eM Client version 6 for all users and logging verbose to logfile.txt.

There are a number of errors in the logfile, but it’s possible it is failing to detect .NET on my Windows 8.1 system. Early errors probably have to do with dialog setup parameters, maybe because I’m running from the command line. The first significant errors look like this:

MSI (s) (DC:84) [13:39:14:563]: Doing action: NetFxScheduleNativeImage
MSI (s) (DC:84) [13:39:14:563]: Note: 1: 2205 2: 3: ActionText
Action 13:39:14: NetFxScheduleNativeImage.
Action start 13:39:14: NetFxScheduleNativeImage.
MSI (s) (DC:74) [13:39:14:577]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIEC93.tmp, Entrypoint: SchedNetFx
SchedNetFx: Error 0x80070570: failed to call FindFirstFileW with string C:\WINDOWS\Microsoft.NET\Framework*
SchedNetFx: Error 0x80070570: failed to search for ngen under path C:\WINDOWS\Microsoft.NET\Framework\
SchedNetFx: Error 0x80070570: failed to get 32bit ngen.exe path
CustomAction NetFxScheduleNativeImage returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 13:39:14: NetFxScheduleNativeImage. Return value 3.

I found a webpage where a Microsoft guy with some .NET tools had to mod his code to correctly detect .NET on 8.1 after it had previously worked on 8.…

It might be related? Not sure.

Have you successfully installed on 8.1?

Actually, further investigation via that link indicates it’s a problem with .NET on my end. As I said in my initial post I did a hard reset at one stage and it appears to have corrupted my .NET installation. Using Microsoft tools via that link to try to detect .NET version also fails. So I’m looking into repairing my Windows installation or possibly a reinstall.

Hi Franc,

I’ve installed eM Client without issues on Windows 8.1

You can download latest version of Microsoft .NET here:

Good luck!

It seems you can’t install .NET alone, since it’s built into 8.1.

But I have reinstalled Windows 8 and then 8.1 on top and just installed eM Client 6 no problem. No problem except rebuilding my OS, which I didn’t really want to do. The whole thread was my fault, not eM Client’s.

I’ve also installed Ubuntu so that the rest of the users on this computer can use their Windows and I can use a (hopefully) more robust OS.

Thank you very much John and Hans for helping me through this.

I have a similar problem. I remove the program (with your uninstaller which also cleans the registry) , remove the directory, delete the database and delete the eMClien directory in users \ App Data \ …

Then I want to re-install the program, but it still find settings active. Where they come from I do not know.

The purpose of this is to make a movie of the installation .

What kind of settings are still ‘active’?

Does the installer find these settings?

Or does eM Client find these settings when you start eM Client?

Do those settings prevent you from installing or running eM Client?

Several bud the most visible was the layout.
Afther i used “Your Uninstaller” in the “Super mode” and manually removed the directorys above, the problem was solved .
Aan uw naam te zien.
Verschillende, maar het meest opvallende was de lay-out.
Uiteraard werd dit gevonden bij het opstarten maar het had geen enkel effect op de werking.
Ik heb het programma daarna verwijderd met “Your uninstaller” in de “Super mode” en handmatig alle mappen die met eM Client te maken hadden. Juist opnieuw geïnstalleerd en geen probleem meer.

‘my uninstaller’? Ik ben geen medewerker van eM Client :slight_smile:

In ieder geval ben ik blij te lezen dat eM Client nu voor u werkt!

I think it’s pretty good. Despite the fact that it sometimes works in a weird way.
Ik vind het best goed. Ondanks het feit dat het soms op een rare manier werkt.
Spijtig dat het de vertalingen doet via Bink en niet , zoals gemeld, via google. Die vertaald stukken beter.

I am sorry but I do not understand, does your conversation mean that issue has been resolved?


Yes, the problem of ‘Efel’ has been resolved by re-installing Windows 8.1 and re-installing eM Client.

I’m using win 7. Not 8. The problem was solved by better uninstalling eM Client.

Why do you use Bing instead of Google?

A suggestion. I have enough with 2 accounts but, might be, a plus version with 5 accounts for non-commercial use and without enterprise support for say $15 be interesting?

I have marked this topic as solved.