Can't synchronize emails in eM Client with two phase authentication Gmail email, need advice

What should I do to get emClient properly to work? I am using two phase authentification on my google email account and even if I have had generated special password for emClient like for other apps via gmail I just can’t get it to work. I have synchronized contacts from Gtalk, maybe even calendar, but emails doesn’t work. It tells something with SMPT connection or connection error. My second email WITHOUT 2-phase authentication is running smoothly. Any advice how to run my email WITH it please? Thanks

Hello,

that connection error message, what exactly does it says?

regards
Jan

This is a possible solution to the problem this person was having. I too had a similar issue with the two-phase authentication of Google for gmail. It has to do with the need for a so-called “application-specific-password”.I followed the instructions and the problem has resolved. Here’s Google’s page of guidelines: https://support.google.com/accounts/a…

Thanks for your answer. I do know about this option and I tried it. But it doen’t work with special password so still searching solution.

[IMAP] An attempt to connect to email failed. This could be caused by temporary server unavaibility or incorrect settings.

18:15:29 [IMAP] MailExceptions.ConnectionException: Failed opening connection to server. —> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 173.194.65.109:143
18:15:29 at System.Net.Sockets.TcpClient…ctor(String hostname, Int32 port)
18:15:29 at MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
18:15:29 at MailClient.Imap.ConnectionPoolEntry.Reconnect()
18:15:29 — End of inner exception stack trace —
18:15:29 at MailClient.Imap.ConnectionPoolEntry.Reconnect()
18:15:29 at MailClient.Imap.ConnectionPoolEntry.Connect()
18:15:29 at MailClient.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle)
18:15:29 at MailClient.Imap.ConnectionPool.AcquireStoreConnection()
18:15:29 at MailClient.Imap.ConnectionContext…ctor(ImapAccount account)
18:15:29 at MailClient.Imap.Synchronizer.SynchronizeFoldersCommand.Execute(WorkerStatus status)
18:15:29 at MailClient.Commands.Command.Process(WorkerStatus status)

I’m sorry, I tried for 4 th time to set up email again and it works now. It was probably my fault (maybe wrong type of special password or something similar). We will see if it happens again or will be ok. Anyway thanks all for you kind help :slight_smile:

Hello, thank you for your update.

regards
Jan

i have configured both yahoo and gmail accounts on em client and both of them don’t connect to the email .its able to get all the other folders but not the email. Is the two way authentication a must for gmail and are there any constraints for yahoo. I guess yahoo doesn’t allow IMAP…

Hello,

please send IMAP logs for your all faulty accounts.

Tools - Settings - Advanced, mark off IMAP under your accounts with this issue and restart eM Client.

after this try to synchronize or authenticate and send me created logs to: galis@emclient.com

together with this URL:
https://discourse.emclient.com/emclient/to…

regards
Jan

Hello,

I just got an idea, do you have similar problems in other software also? Because your connection often timeout (at least it looks like it) this might be caused by firewall or/and antivir without proper setup.

regards
Jan

I have the same problem, how can I solve it? Please help me!!

most issues with two phase authentication are with bad password, can you please check that you are putting right password or you are having right configuration.

with regards
Jan

This is a repost…but worth sharing. If you use Google/Gmail 2-step authorization, then you will need to generate a new password that only emClient will use. Do this through your gmail account settings: Account - Security(tab) - 2-step verification(settings) - App Specific Passwords - Manage app specific passwords - (generate one for emClient).

Also, you may have to authorize your computer as well (you probably already did that when you enabled 2-step authentication at some point).

Cheers!

thank you for posting this, it will be very useful for other users :slight_smile:

Jan