Can't send outgoing mail "Cannot send message (email recipient not accepted by the server"

I was not able to send any outgoing mail and was getting this error message “Cannot send message (email recipient not accepted by the server”.  I checked replies on the forum for this error message and most common reply was an incorrect address was used.  My address was correct and got this error for all email addresses.  One reply suggested account settings was wrong so I checked into that and under “SMTP” I found “Server requires authentication” turned off.  I turned it on which then showed on for “use identity credentials”.  This fixed my problem.

Glad you got it sorted Priya. Was the incorrect setting there after initially adding your email account, or was this something that changed recently?

Who is your email provider?

I had been using Em client for a number of years without problem and then recently my computer hung up and wouldn’t reboot so I selected from the message “Return your computer to its original settings” which deleted all non-microsoft applications including Em Client.  Once I got my bare bones computer back up I re-installed Em client and it would receive incoming mail but wouldn’t send out outgoing mail unless it was to myself or my husband who is on the same IP address as me.

My email provider is Sasktel.

If you go to your account settings and check that you have the following:

Port: 25
Security policy: Use SSL/TLS if available

Under Authentication, check Server requires Authentication, and use identity credentials.

Let me know if that works.

It was working after I turned on “Server requires authentication” in SMTP.  Thanks for the additional possible settings.  I’ll put this aside for the future if I ever have my computer crash again and I have to resort back to the original microsoft settings.

Glad it worked out for you.

Yes, me too.  I tried using the Windows 10 mail but didn’t like it.  I spent several days without outgoing mail until today I bit the bullet and decided to try and figure out what’s wrong.  I happened to “guess” on the right setting.