Can't send mails

Since the latest update last week I have not been able to send emails. I get the error "unexpected end of stream. I am absolutely confident the imap and smtp settings are correct. As a test I installed Mozilla’s Thunderbird and it works perfectly.

Disable your anti-virus application and see if there is any difference.

I did and there wasn’t :frowning:

Go to Menu > Tools > Accounts and make sure that the SMTP settings are port 587 and the security policy is set to Force usage of SSL/TLS. Then disable your anti-virus application and try again.

Who is your email provider James?

I’ve done that too to no effect. I even completely uninstalled the program and reinstalled. My email provider is sky/Yahoo.
Thanks & Regards, Jim

The last update was back in May, but you can always uninstall the eM Client update and then download the previous version from the Release History and install that. At least that will get you back to a working application.

Thanks, Gary. Will give it a try.

Didn’t work Gary. Same "unexpected end of stream " error. Can I delete the account and set it up from scratch, so the account settings are got from sky/Yahoo? What I can’t understand is how Mozilla’s Thunderbird, which I installed as a back up, works perfectly. Might be worth noting that I cannot access this forum from my PC either using Firefox or Edge, but only from my Samsung S8. I’ll see if I have pop ups blocked - might be preventing me logging in to forum.

Yes, as it is an IMAP account you can remove it and add it again. If your email address ends in, eM Client will not get the settings from the server, but instead use a preconfigured setup. 

This will use the following server details:
IMAP 993
SMTP 465

Which is the same settings as Thunderbird will get from the server. eM Client just sets the appropriate security policies from it’s config file. 

I did notice that both eM Client and Thunderbird use port 465 for SMTP. If you prefer to use that set the security policy to Use SSL/TLS on special port (legacy)

Tried the settings also port 587. Deleted account and reinstalled. Now getting error: [IMAP] An attempt to connect to to ******** failed. This could be caused by temporary server unavailability or incorrect settings. Do you want to check the settings.

Needless to say I’ve tried every combination of settings!

And I still can only login to this forum via :Chrome on my mobile even after disabling popups on Firefox.

The settings require a specific combination of port and security policy otherwise they will not work.

Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

Port 993 = Use SSL/TLS on special port (legacy)
Port 143 = Use SSL/TLS if available

The other possibility is that it is a server issue. BT had huge problems recently, so it is not unheard of. You could try contacting your email provider and see if there is something they can advise.

Thanks, Gary. I think I’ve tried all these but I will do so again. Could there be a server issue that would affect only eM Client?

If the settings are correct but eM Client is still not connecting when Thunderbird can, then that is most probably the application is being blocked by an anti-virus/firewall or other security application.

Some applications are not as forgiving as Thunderbird with unusual server configurations. Sky shouldn’t be a problem though.

I’ll investigate. Problem is, as fas as I know nothing changed on my PC to cause the problem!
Thanks again.

It seems that a breakthrough has occurred: I have had several messages in the outbox waiting to go. No market what I did they stayed there. From time to time I selected one and tried to resend to no avail. I have just done so again and the message went! I did the same with the others and they went too as did a new message. Settings are

IMAP 993=UseSSL/TLS on special port (legacy)
SMTP 587=Force usage of SSL/TLS

I have used these settings before so why they chose to work now, I don’t know.

Now to find why I can’t log into this forum from Firefox or Edge on my PC!

Thanks for the help
Regards Jim

Cox is my provider. I used Tbird for years and never had a problem until new update. Would not let me send without continuously entering password but had no problem receiving. Switched to eMClient and worked fine for a few days. Now it keeps showing error message “unexpected end of stream”. I hit ignore and msg goes thru. I tried changing outgoing port to 587 but still same problem. Went back or original port, 465, but nothing seems to work. I ran the diagnostics and said, “ok”.  The good thing I can say is that msg goes thru once I hit ignore.