Can't save unicode txt attachment as unicode

Windows 10 eM Client(Personal)

When I saved attachments .txt files encoded in unicode(UCS2/UTF16), I could not save as unicode as it is. It is somehow saved as ASCII text file. So all the unicodes in the file are gone. 

Is it a bug? or is there anything I missed in setting? 

I tried it out a few times, I tried to change even windows global unicode setting so that windows forces non-unicode supported applications to use UTF-8 encoding, but helpless.

When I downloaded them directly from browser(gmail), no problem at all. All unicode texts are saved properly. 

Looking forward to help.

Check if attachment was truly send as UTF-16 - look in message source:

Content-Type: text/plain; name=attachment.txt; charset=utf-16
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename=attachment.txt

Outlook has a bad habit to set wrong content-type charset and while some programs do not use this information, it could be EmClient use it.

Hi Sylwester,

  1. In message header, there is no charset=utf-16 defined for the attachments.

  2. As for the message body(not attachments), it sets utf-8

  3. Even though Outlook or sender doesn’t set the content-type accordingly, there is no problem with other email clients like Apple Mail on OSX, Google Mail via browser. I could download the attachments as the expected unicode txt files. 

  4. It’s confirmed that all the attachments are surely created and saved as unicode (UCS2 encoding).

  5. Only eM Client is not able to save the attachments as expected.


I was afraid of it, it looks like eM Client should write all attachments as is = binary, without any encoding for compatibility purpose.

Yes, I have mail with this trouble too.