Can't restore prior backup

I’ve been trying IMAP for awhile and decided to switch back to POP3 to conduct some diagnostic tests requested by Gary. Unfortunately, I’ve been unable thus far to restore from the previously created POP backups. The first attachment shows the error message while the second attachment shows the contents of the selected file.
Can’t figure out what I’m doing wrong?

Don’t extract the zip files.

eM Client needs the original zip backup file to restore, so point it to the directory where that zip file is located.

Thanks for the reply. I should note that I have both IMAP and POP backkups moved into separate folders. Is it necessary to do a restore from the folder in which the backup was originally created? In case that was true I moved the most recent POP backup into D:\Data\eM\Backup in case that was true. When I attempted to do a restore I got the following message:

System.IO.IOException: Access to the path ‘D:\Data\eM\eM Client’ is denied.
at System.IO.FileSystem.MoveDirectory(String sourceFullPath, String destFullPath)
at System.IO.Directory.Move(String sourceDirName, String destDirName)
at MailClient.DbBackup.FormBackup.Restore(String backupFile, CancellationToken cancellationToken)
at MailClient.DbBackup.FormBackup.Restore(CancellationToken cancellationToken)
at MailClient.DbBackup.FormBackup.<>c__DisplayClass28_0.<MainForm_Load>b__0(Object a, DoWorkEventArgs b)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

I rebooted the computer in an attempt to clear the issue. I then tried to do the restore and again I got the error indicated above. The folder where the backup is stored is shown below. I had moved the zip backup into the folder in which it was originally created.

This is your database location?

Do you have full permission on that folder?

Yes, that is my database location. As far as I know, I have full permissions. Here is the property window for that folder:

The folder I save backups to is: D:\Data\eM\Backup. I then move them into either D:\Data\eM\Backup\IMAPbackups or D:\Data\eM\Backup\POPbackups to keep POP and IMAP separate

The full control option is not selected.

What happened recently that you lost permissions? Did you update Windows?

Thanks. I don’t know what happened other than my several attempts to do a restore. I have not updated Windows recently although some updates may occur automatically.

I just edited it to give full control and reattempted the restore. Received the same error message.

I would suggest to move your EMC file to your C: Drive somewhere and see if they will then restore.

Thanks. That doesn’t work since the error occurs immediately before even having the chance to select the backup location.

Wonder if I should move the eMC database location then try again?

Update: moved both database and backup locations. Now able to run the restore without issues