can't establish imap connect to alibaba-inc.com

corporation mail server: alibaba-inc.com
smtp is ok
imap cant be established, it keeps telling me to input correct password, I’m sure about that I have input my password correctly.

I have the imap log, to whom I can send this log?

Hello Dmmc,
can you test if you can login into your mail account using a webmail interface through Internet Explorer (if you are using eM Client version 6) and Chrome (if you are using eM Client 7) and then try setting up your account again?
If the issue is your credentials being rejected, IMAP logs will not have any useful information.

Regards,
Olivia

hi, yes, I’m using eM Client 6, I can login with Chrome, outlook, thunderbird, mailbird, postman etc. I even tried to import settings from thunderbird and outlook, but it keeps telling me :
Password required,Server says “failed”

My password contains some special characters like “@” and “*”, does this matter?
thanks

sorry, I’m using eM Client 6.

eM Client 7 can’t work properly neither.
email server was detected, but credential were rejected.

Could you please copy the error message that you see and the content of the Tools>Operations>Log window here?

Regards,
Olivia

I’ve send all the logs to support@emclient.com

are those logs helpful ?

Password required

Server says “failed”

When I click “Fix” to the imap setting:
An email server was detected, however your credentials were rejected. Do you want to try again using different a password or username

When I input the correct username and password.
It says :“Fixing failed”.

In the Logs:
14:56:22.917|014|   * OK AliYun IMAP Server Ready(10.182.156.86)
14:56:22.917|013|   A0 CAPABILITY
14:56:22.971|014|   * CAPABILITY IMAP4rev1 IDLE XLIST UIDPLUS ID SASL-IR AUTH=XOAUTH AUTH=EXTERNAL
14:56:22.973|014|   A0 OK CAPABILITY completed
14:56:22.973|013|   A1 ID (“name” “eM Client” “version” “6.0.24928.0” “GUID” “1”)
14:56:23.006|014|   * ID (“name” “AliyunImap” “vendor” “Aliyun, Inc.” “url” "http://www.aliyun.com")
14:56:23.006|014|   A1 OK ID completed
14:56:23.006|013|   A2 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:23.049|014|   A2 NO AUTHENTICATE failed
14:56:24.728|013|   A3 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:24.758|014|   A3 NO AUTHENTICATE failed
14:56:55.439|013|   A4 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:55.470|014|   A4 NO AUTHENTICATE failed
14:56:56.063|013|   A5 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.094|014|   A5 NO AUTHENTICATE failed
14:56:56.237|013|   A6 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.270|014|   A6 NO AUTHENTICATE failed
14:56:56.381|013|   A7 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.417|014|   A7 NO AUTHENTICATE failed
14:56:56.521|013|   A8 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.558|014|   A8 NO AUTHENTICATE failed
14:56:56.671|013|   A9 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.701|014|   A9 NO AUTHENTICATE failed
14:56:56.806|013|   A10 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.838|014|   A10 NO AUTHENTICATE failed
14:56:56.948|013|   A11 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:56.979|014|   A11 NO AUTHENTICATE failed
14:56:57.105|013|   A12 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:57.241|014|   A12 NO AUTHENTICATE failed
14:56:57.406|013|   A13 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:57.441|014|   A13 NO AUTHENTICATE failed
14:56:57.580|013|   A14 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:57.610|014|   A14 NO AUTHENTICATE failed
14:56:57.731|013|   A15 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:57.763|014|   A15 NO AUTHENTICATE failed
14:56:57.879|013|   A16 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:57.909|014|   A16 NO AUTHENTICATE failed
14:56:58.030|013|   A17 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:58.060|014|   A17 NO AUTHENTICATE failed
14:56:58.179|013|   A18 AUTHENTICATE EXTERNAL eWluZ2ppZS5kb25nQGFsaWJhYmEtaW5jLmNvbQ==
14:56:58.210|014|   A18 NO AUTHENTICATE failed

the same imap settings can work in Mailbird and outlook and thunderbird and postbox

Hello,
this only shows that the problem is with the credentials being rejected for some reason, not the IMAP setting - does your server perhaps block certain apps? Perhaps some kind of additional verification needed?
Try looking at the Tools>Accounts setting and under IMAP try different SSL security policy.

Regards,
Olivia

I tried all four ssl security policies. only the last one using 993 port gave me response and said “Server says ‘failed’.” and asked me to input the correct password. All the other 3 said :

11:35:38 yingjie.dong@alibaba-inc.com [IMAP]  MailExceptions.ConnectionException: Failed opening connection to server. —> System.Net.Sockets.SocketException: 由于连接方在一段时间后没有正确答复或连接的主机没有反应,连接尝试失败。 140.205.121.207:143
11:35:38    在 System.Net.Sockets.TcpClient…ctor(String hostname, Int32 port)
11:35:38    在 MailClient.Imap.Base.Connection.<>c__DisplayClassa.b__9()
11:35:38 在 MailClient.Imap.Base.Connection.Connect(Func`1 getStream)
11:35:38 在 MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
11:35:38 在 MailClient.Imap.ConnectionPoolEntry.Reconnect()
11:35:38 — 内部异常堆栈跟踪的结尾 —
11:35:38 在 MailClient.Imap.ConnectionPoolEntry.Reconnect()
11:35:38 在 MailClient.Imap.ConnectionPoolEntry.Connect()
11:35:38 在 MailClient.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
11:35:38 在 MailClient.Imap.ConnectionContext…ctor(ImapAccount account)
11:35:38 在 MailClient.Imap.Synchronizer.CreateFolderCommand.ExecuteInternal(WorkerStatus status)
11:35:38 在 MailClient.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
11:35:38 在 MailClient.Commands.Command.Process(WorkerStatus status)

This is a corporation email. the same setting in other email clients can work:
imap.alibaba-inc.com:993 ssl/tls

Hello,
try using the legacy port server security policy and add an exception for eM Client in your Firewall and antivirus software.

Regards,
Olivia

yes , I’ve tried all four policy and only the special port (legacy) has some response and asked me to input password, all the left 3 policies setting come to : server 30 senconds no response.
I’ve shutdown antivirus and firewall.

Have you tried entering your user name without the domain part?

Regards,
Olivia

yes, but unfortunately, Server says “failed”…

I’m sorry, but it seems the issue really must be on the server side. If the user name and password is indeed correct but the server won’t let the authentication pass, then we cannot do much more from the client side.
Please contact your server provider and ask them to go through the server logs and find out why the authentication cannot be performed.

Regards,
Olivia

yes,it was really odd. I’ll give it a try.
Thanks very much for helping me tracking this down  :slight_smile: