Cant encrypt: "No valid PGP keys were found"

I’ve testing out PGP using two different email accounts (1 yahoo, 1 gmail) tied to two different machines, each running emClient

I’ve created the keys for each account, shared the public key for each, and yet still can’t send encrypted messages.

Here is the prompt I get:

I don’t know why its telling me it has no keys.  In order to send an encrypted email from my yahoo account to my gmail account, the only thing my yahoo account *should* need is my gmail account’s public key, right?  Here they are:

Here’s a screenshot from my gmail connected emClient.  Does there appear to be anything wrong about this?

I have already tried deleting all keys, resharing them, reattempting.  All to no avail.
The key creation and subsequent importing process all goes to plan, according to emClient.  No error messages during those steps…

I am wondering if you have PGP keys for both recipients, as there are two listed in the error?

They are not both recipients.  The yahoo account is trying to send an encrypted message to the gmail one using the gmail account’s public key.
The white theme screen shots are the yahoo client
The black is the google.
The yahoo client (white) clearly has a public key for the gmail.  There shouldn’t be any more than that necessary for the yahoo to send an encrypted email to google, no?

There were some fixes related to encryption in the more recent versions of eM Client. So one thing you could try is to update to the latest version if you are not already using it. The latest update 7.1.32088.0, is available to download at http://www.emclient.com/release-history.

Just installed yesterday, so already using that

OK, so that’s not it then.

The error from the yahoo installation seems to think it is missing keys for two recipients. I just did a test with multiple recipients, and I only get those addresses listed in the error for which there is no public key. Is it possible you have your account configured with automatic BCC to other addresses? Are the two addresses listed in the error the same as those for which you have public keys?

Chris, send me an encrypted email at gary.curtin@gmail.com. You can find my public key at https://drive.google.com/open?id=1U6ZmvqJULQ4wA06gpr0yj909Vhqr423K

Still failing:

Not sure why.  The software seems to think it successfully imported your public key:

At least we know it is not the key because I just sent an encrypted message to my gmail address using the same public key. It worked as expected and I received the encrypted message.

Got me stumped Chris. I will look at this again tomorrow.

For some reason, I don’t see “Password is required”, I get this:

Not sure what it means by the certificate is not “found”, its right here isnt it?:

I thought I’d test if the KEYS were somehow the problem, so I installed Mozilla Thunderbird.  So now I’ve got both clients running, connecting to the same email accounts and using the same keys (I think).

Here’s the key in Thunderbird’s key manager.  Looks same as in eM client:

And here’s the encrypted, signed message successfully arriving:

How is that possible?  And what is all this talk about “certificates” anyway I though PGP was “keys”?

In your screenshot, it appears that there is a problem with encryption. Not the message, but with eM Client itself. This is also proved by you testing the message in Thunderbird. Can you reinstall eM Client and see if that fixes it. Maybe download the install file again. You will not lose your data.

Another thing is that eM Client relies on .Net Framework. Maybe check that yours is up to date in your Windows settings. The latest stable version is 4.7.1.

What version of Windows are you using?

It is technically a key certificate, so I guess the words are interchangeable.