Can't download emails - HELP

I am new and setting up, and can’t download emails.
1) my gmail account emails downloaded just fine.
2) my first 14k-some emails seemed to download okay though there were several breaks, errors, but it had been resuming download; until now.
3) under Accounts , I only have POP3 and SMTP tabs   (no IMAP tab)
4) i updated my SMTP settings as follows per another thread:
__Port: 587
__Security policy: Force usage of SSL/TLS
5) i have your free/2 email service
6) latest error in log:  7:11:08 PM ***** [POP3]  MailClient.Accounts.SocketException: Error when receiving from account  ***** : Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Help!  Thanks!

Check to see if you have one of the following settings for POP3:

For Port 995, Use SSL/TLS on special port (legacy)
or for Port 110, Use SSL/TLS if available

i tried both POP3 settings.  Not working…

Can you disable your anti-virus application, then try again?

Disabled Windows 10 Defender and retried both POP3 settings.

Not working.

I see on the Internet that they have different servers.

Which one is being used in your POP settings? If neither, can you try changing to the above and see what happens.

where do i change the server address? not seeing it under the POP3 tab.  

Sorry. That is the Host, so replace with the alternative and see what happens.

tried both host addresses and still not working :frowning:

also, the antivirus was off that whole time i was trying that. 

if the mail was able to download 14k emails, why would it suddenly stop?? going to bed now, but pls send some ideas.  thanks.

Is there maybe not an issue with the provider? That would explain why it did work, and now doesn’t.