Can't delete folders

Just installed eM Client. I tried importing messages from an old message store. There was just a single message I wanted. That worked, but now I can’t delete the folder. I’ve tried moving it to trash, I’ve tried delete, it just makes a copy in Trash, and the original stays. Empty Trash doesn’t work either. The folder stays in trash.

I’ve tried uninstalling. I’ve completely deleted the folder, made sure all files were gone, then reinstalled. The folder is still there.

My trash now has multiple copies of the same folder, which I don’t want.

What do I do?

This looks to be a much nicer application than Windows 10 mail, so I hope I won’t have to abandon it.

What folder is it?

If it is a sub-folder on an IMAP or Exchange account, try removing the folder using the web interface for your email account.

I created a folder called OLd  messages and imported. The messages all are in a subfolder called archived mail messages.

The Trash is full of folders called Archived mail messages_x and Old messages_x

I’m  not sure what you mean about web interface. These are messages imported from the message store of an old version of Winmail. There was no web interface.

Open your web browser and login to the web interface for your email provider. That means if your email address end in, open the Gmail web site. If your email address end in, open the Yahoo! email web site. If your email address is . . . . . 

The messages are not being downloaded. They were stored on my local computer and I imported them.

The original email account in which I received them is now defunct. I cannot log into it either on my desktop email client or on the website. 

I have a new email address which I’m using. Logging into the website for that, I only see my recent messages. The problem folders are not there. 

OK, so it is a sub-folder of Local Folders.

It may be that the database has become corrupt. Close eM Client and run C:\Program Files (x86)\eM Client\DbRepair.exe. See if that helps.

That sounds promising.

When I tried it said I had to register first. When I tried to register, I got a message “Unknown error … try again later”

I’ll have to wait a while before I try it.

Mine are still there in spite of deleting them on RoadRunner’s service, trying the DbRepair.exe, and un-installing emClient and re-installing it.  I wish I could get rid of them.  I am constantly checking in my trash to see if there is anything I forgot to delete, only to find those 4-6 folders.  I would give anything to solve this…  anybody have anything new I can try?  I got so frustrated last night that I search for other email clients and tried four, but none of them are anywhere near as good as emClient, even with this crazy glitch.

Uninstalling eM Client will not remove the message cache unless you also delete the database directory.

Another option is to just remove the account from eM Client, and then add it again. eM Client will only sync what is on the server, so once the account is added, you should have an exact duplicate of what is on the server.

1 Like