can't delete an email

I have an email with an attachment that I can’t re-open and can’t delete or move.
It’s from a safe supplier of mine, but it’s stuck in the inbox.
Any way of deleting it from it’s location directory (wherever that is)?

I’m afraid I don’t have an answer - but I do have the same problem.  I have an email from a regular source that only has a heading - but nothing in the body of the message. It won’t delete either. When I was using Windows Live Mail you could, with a bit of work, find the actual message and delete it from ‘outside’ of WLM, but with eM Client the individual messages are not accessible as far as I can see.

If you find an answer, please let me know what it is!  

I have a similar problem, not usually in the inbox, but with drafts and in the deleted folder. I’ve found a workaround, but it means logging on to my ISPs webmail to look at my mail, and deleting the persisting files there. This makes me think it’s a problem with IMAP sync, but I’m not techie enough to know what this really means. I’ve not had this problem with any other email client. 

Hello Paul,
what mail account does this happen with? And with what eM Client version (Menu>Help>About)?
Are there any error messages in Menu>Tools>Operations window when such message gets ‘stuck’?


Hi Olivia - I said ISP but I should have said hosting service. I use a British company called 34sp, and it’s true that as far as I can remember this problem only occurs on mail on that account, rather than gmail or outlook. I’m afraid I’ve switched off the error messages because they’d happen with every connection problem however momentary and didn’t seem to mean much, so were more irritating than helpful. I’m using version 7.0.27934.0

 I’ve used practically every email client going, and not had this problem with any other. Then again if it’s any comfort, it’s only a minor irritation, and all in all it seems eMclient is about the most usable (and only) fully featured email client still in the game

Same problem; my issue is with an iCloud account I added to eM. There’s an email from 2014 that I deleted long ago that shows up in the inbox. It does not appear in mail on iPhone, or in the iCloud mail viewer. It must be on the Apple servers to show up, but is presumably malformed in some way and the Apple mail viewers know to ignore it. I can’t do anything with it; there’s a subject line but no message content; I cannot delete or move it. I tried repairing the inbox with no effect. I tried removing and re-adding the account with no effect. Likely this is really an Apple bug, but perhaps eM client can hide emails that are deleted locally but fail to delete on the server. I’d really prefer to not have to look at this one email for the rest of my life!

oh wait! nevermind! I found these instructions in another thread and bingo, the stuck email is gone;
Turn Conversations off (Menu -> View -> Conversations -> Disable Conversations)
Turn eM Client off
Go to eM Client’s installation folder (C:\Program Files (x86)\eM Client) and run DbRepair.exe (not the DbRepair.exe.config). Wait until the database check is completed.
Turn eM Client on