Can't connect via SMTP

I’m successfully receiving mail, but not sending. I’ve checked many times, and my settings appear to be correct. Under my STMP tab in the account, I have:
Host: ssih.com
Port: 25
Security policy: Don’t use
Server requires authentication: checked
Use these credentials (and credentials filled out correctly - checked many times)

From the log file:
7:52:03 AM pat@ssih.com [SMTP] Connecting: To pat@ssih.com
7:52:24 AM pat@ssih.com [SMTP] MailExceptions.SocketException: Connect failed with reason:
7:52:24 AM “A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 204.12.61.116:25”
7:52:24 AM at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
7:52:24 AM at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
7:52:24 AM at MailClient.Commands.Command.Process(WorkerStatus status)

(204.12.61.116 is the correct IP address)

I have access to my mail server logs, and it shows no failed attempts to log in by me. I have firewall turned off on my PC.

I know that SMTP is working on that port:

$ telnet ssih.com 25
Trying 204.12.61.116…
Connected to ssih.com.
Escape character is ‘^]’.
220 mail.ssih.com ESMTP Postfix

Any suggestions?

Solved. Turns out Verizon is blocking port 25.

Hi, I’m glad it works now. Thank you for the solution for other users experiencing this issue.

Paul.