Can't add CalDAV / CardDAV account

I have created a new account within eM Client to connect to my calendar and contacts server. I’m not getting errors but they are not appearing within the Contacts & Calendar section. I looked at the accounts configuration and see a spot to specify Default Folders for each however every folder I try to select or create, it tells me that the folder selected doesn’t support the required item type.

What am I missing? 

I have basically the same problem on the Mac beta version. I had no problems on the windows version. The difference that I see is that on the Windows version it created the needed folders besides the local folders whereas on the Mac I seem to be unable to create a folder besides the local folders. Any help is much appreciated.

I think that Jeff’s problem may be that he does not have the correct CalDAV and CardDAV URIs. 

As for the Mac version, no idea. I would assume that if you used the same URI and credentials as in Windows eM Client, you would have the same result.

What happens if you export the settings from Windows and import them into the Mac version? You can do that through Menu > File > Export > Export settings to .xml file. I am not sure if the applications are compatible that way, so you would have to try it yourself. Or even if you backup the Windows version and restore it on the Mac.

Thank you for the quick response.
I have the identical URI and credentials in Mac as on Windows. The only difference is on the folder in the eM client: On Windows, it created a folder next to the local folders for both calendar and contacts, but not on Mac. And on Mac it does not allow me to create a new folder which is not under the local folder.
The XML Export worked, but not the import, an error message appeared. So I compared the xml from Windows and Mac, but there is no difference on the accounts. The xml contains no information on the folder structure.

So there must be some differences between the two versions. Do you have a contact at eM Client for beta testing? 

Unfortunately not, do you know a contact?

I found the solution: It was a misspelling on the URI, I use SOGo, and I did not add enter the capital letters for it. Thanks for helping me!

Right. So incorrect URI = headache. :slight_smile:

I thought because the Mac version was not a public beta, an employee must have given you the download link.

Mac is actually public beta, I found it with Google :slight_smile: