Cannot send email for 3 days

Not sure if this is an emclient issue or a server issue.

I’m using emclient version 8 1 979 (65fd04a)

For almost 3 days now I am receiving emails but outgoing messages are not sent, they stay in the outbox. There are three messages stuck there at the moment. Whenever a send/receive refresh is done the “operations” list shows three identical error messages (presumably one for each message). The message says An error occurred
(SMTP)Cannot send message (Email recipient not accepted by the server).

The three messages are for friends with whom I have regular contacts, so it’s extremely unlikely that all three have suddenly disappeared or anything like that.

I checked the SMTP settings for the cox account:
The server is, port 2525, security policy “Don’t use secure connection”
Authentication: “Server requires authentication” is checked, “Use identity credentials” is unchecked, “Use these credentials” is checked followed by user name and password.

To be honest, I have no idea why the SMTP settings are as they are, I’m guessing this was all set up by emclient at some stage. I’ve been using emc for at least 3 years with almost no problems.

Any advice appreciated,



The server name is not valid, neither is port 2525. Maybe a typing error?

Go to Menu > Accounts and click on the SMTP tab for your email address. Change the port to 587 and the security policy to Force usage of SSL/TLS.

You can use 25 and Use SSL/TLS if available if you want, but port 587 is a better option because port 25 will not work on all networks.

Tick Use Identity Credentials. You already know that you can receive messages, so they must be correct. Ticking this option allows you to use the same credentials for both send and receive. Unless you are using a different server for sending than you are for receiving, then leave it as it is.

If changing the port settings did not help, then disable your anti-virus/firewall application and try again.

If the messages send, then you will need to re-configure your anti-virus/firewall before enabling it again.

This is another issue. The address you are sending the message to is not accepted by the server. Delete the message and try again with a different address.

Thank you so much for your prompt response Gary.

In brief - no joy.

I changed the port to 587, no success. I closed emc and restarted it - no success. I then changed the security policy to “Force…”. No success, closed emc, restarted it - no success.

You mentioned about “” that “the server name is invalid”. And also port “2525” being invalid. Before contacting you I did quite a bit of research. I kept coming up with smtp2go instead of smtpcorp (???!) As I mentioned, I have no idea where these settings came from, I don’t understand the process to be honest, and how one would choose an SMTP server. But for sure, the settings have “never” been changed, and it would take quite a series of accidental key depressions to find a way to the SMTP screen, make changes and save them.

Anti-virus/firewall is Windows defender. I disabled it, no success. I closed the machine, started it, (with defender off),=. No success. I have set it back on again.

Also, the server for receiving messages is, port 110, so I didn’t attempt your suggestion of setting “Use identity credentials”.

The only thing that’s changed in the past few days is that on Saturday I installed the latest emc. (I have always installed updates whenever they arrive.) I can’t be 100% sure, but I’m thinking that since then no emails have been successfully sent. Certainly there’s nothing in “Sent” dated after Saturday.

Would it be an idea to use a different server? But I have no idea about how I would choose one. And, as I say, I have no idea where the current settings came from. I switched to emc after Outlook was withdrawn. When I was using Outlook I remember having to play around with the account settings when moving from country to country (I spend some time each year in the US). But - again from memory - when I switched to emc I was dreading setting up the account info, but (from memory) emc seemed to do it all by magic.

Any further advice gratefully welcomed.


Windows Defender does not affect eM Client. Usually the ability to receive but not send is because of an application like Avast. But if that is not installed, then it must be something else, most likely your settings.

The SMTP details you will get from your email provider. That is a place to start. Once you have them, enter them in the SMTP tab for your account.

Sometimes just restarting your router may make a difference. So that is also something you can try.

Googling around on the subject of or

Appears anyone who used to use either of the above is now changed to

SMTP Settings – SMTP2GO Support

If you have previously been advised to use either or as your SMTP server, you may find that some devices (e.g. routers from Netgear) are unable to send due to the lack of a subdomain.

We now recommend that all members use SMTP server

The following SMTP ports are available:
TLS or no encryption >> available on ports 25, 2525, 8025, 587 and 80.
SSL >> available on ports 465, 8465 and 443.

To see your SMTP username and password you will need to log in to your SMTP2GO account and choose ‘Settings’ > ‘SMTP Users’.

Firstly - Gary. Thank you so much, I now understand (sort of ) where one would find which servers to use! Therefore I checked on Cox is a US-based telecomms company. Their SMTP server is, which makes sense because I have for my POP3 server, and incoming emails have had no problem. For the SMTP Cox shows a couple of combinations of port number and security policy. None have worked. However, the final combination caused a different Cox error message, giving an error code and where to find what it means. It means the account has been blocked as a possible source of spam. Now, that is 100% not true. HOWEVER… I split my year between the US and Cyprus. I have been back in Cyprus since August. A fact that I have to live with is that there are a few US-based websites that bar access from IP addresses in Cyprus and/or behave oddly. I am remembering that some time ago I had some problem accessing Cox from Cyprus, and that I called someone and maybe it was at that time that the smtp server was changed to

Secondly, to cyberzork. Many thanks for your research. I didn’t find what you found. One thing I did find about smtp2go is that it seems you need an account. Well, I haven’t such an account, and I haven’t yet looked into all of that.

HOWEVER, for both of you… When I was looking at Cox I stumbled across a statement from them from August 2019 that said they were closing their email service to new accounts. From further comments, people are guessing it’s unprofitable and that sooner or later Cox will pull the plug on existing clients (almost 20 years in my case).

So… I’m now thinking of changing my email provider, an awful prospect with so many websites having my cox address and so many contacts to inform.

In the meantime, I have a workaround for outgoing messages - a hotmail account that I use for work stuff, and/or notecards from jacquielawson. So for now I’m not going to look further for a fix to my recent problem while I decide whether to move away from Cox.

I will update this with any further news, and thank you so much for your prompt suggestions. My career was in IT, but my brain won’t cope any more!


The mind boggles. :crazy_face: 2525 has never been an official SMTP port and 80 is for HTTP pages. I wonder who’s idea it was to do something like that? Officially port 587 and 25 are the only ones for SMTP.

@keitho, the problem with port 25 is that it may work when the email server is on the same network as the Internet provider, so if your Internet provider is also your email provider. But when moving around, when you are on a public or other network (from a different provider), port 25 may not work at all.

1 Like

All this is beyond my pay grade. All I know is that since I started using emc 3+ years ago, and with settings that I haven’t changed, I was successfully using emc, using the same computer, in Cyprus, the USA, in airports, hotels in several countries, even on cruise ships in mid-Atlantic. Exactly as a non-techie user would want. Open the lid, open emc - voila! No hassle.

So why, suddenly…

Thanks again for your input. I’m still thinking about switching to hotmail or something. Bite the bullet.


Yes @Gary Port 2525 is weird :crazy_face: and i’ve never heard of it before.

I did some more Googling around and its apparently an (alt non official port) that mirrors port 587, but most ISP’s (do not support it). @keitho could be your ISP no longer supports that 2525 port. Best to use the regular / normal SMTP Server & Port Settings in EM Client.

What is SMTP Port 2525

SMTP Port 2525 is not an official/authenticated port, also it is not endorsed by the IETF nor IANA. Instead, Apparently some ISP’s provide it as an alternate port, which mirrors port 587, in the event the normal SMTP ports are blocked.

Because SMTP Port 2525 is a non-traditional special port number, it is typically provided on some Consumer ISPs and Cloud Hosting providers, like Google Compute Engine. If you’ve tried the usual SMTP ports, but encounter connectivity problems, try port 2525.

This SMTP port 2525 also supports TLS encryption.

Thanks again for your input. In an attempt to retrieve the situation I thought I’d use smtp2go. Problem: it doesn’t accept private individuals, it needs an email address with its own domain (I think I’m using the right terminology. smtp2go won’t accept a hotmail or gmail account, for example, and didn’t accept cox.) So I chatted with smtp2go’s support and asked if they knew of an alternative. “Try sendgrid”. So I looked it up - same situation.

So I’m back to contemplating a change of my main email address. Ugh.

I guess you two are volunteers? Well, bless you.