Cannot send attachments with Gmail


I have added my gmail account using the new app password method. I can send emails without attachments, but emails with attachments create an SMTP error.

The error says an attempt to connect via SMTP failed.

Any help here? if I can make it work, i will upgrade from the free version.

Todd Massidda

If you are using a username and password for the Gmail account in eM Client, you will need to setup your account again as that method is no longer supported by Google.

Please follow the instructions here: Google ‘less secure apps’ access and what it means for eM Client | eM Client


I checked per the link and the username and PW section were missing. I deleted and readded the account again using the instructions. The username and PW section are still missing. Emails without attachments send fine. Emails with attachments get the below error.

What’s next?


As a test, can you completely disable any anti-virus, firewall, proxy or VPN, then try send again.
Sometimes even restarting your router may resolve this.

Tried all on the list, still not able to send attachments,

Anything else to try?



I checked per the link and the username and PW section were missing. I deleted and re-added the account again using the instructions. The username and PW section are still missing.

Can you screenshot where the username and password are showing missing ? As you shouldn’t have a missing username and password section in your Gmail account as @Gary advised above.

Are you setting your Gmail account up in eM Client via the “Automatic email wizard” ? where at the end of the email wizard you get a browser “allow window appear” to click to enable eM Client access to your Gmail account.

If your Gmail account is setup via the automatic email setup then you will see the below IMAP and SMTP Tabs in your Gmail account via “Menu / Accounts”. No username & password showing at all.

I setup via the wizard and got the web-page prompts to allow Google access.



Any updates on what I posted?


You have the correct Gmail IMAP & SMTP automatic wizard settings and you have allowed eM Client access to your Gmail account as you said via the browser so nothing wrong there.

From the error you are getting in your screenshot I suspect as @Gary did that it then sounds like then some sort of “optional program installed” on your computer interfering with eM Client sending attachments, as those same Gmail settings work fine for me sending any attachments using eM Client for Windows or Mac.

So as you have already tried disabling any optional Firewall / Security programs, optional Antivirus programs and VPNs etc, try next uninstalling and reinstalling eM Client to see if that makes any difference.

Before uninstalling eM Client, make a backup via “Menu / Backup”. You can see when the backup is completed via “Menu / Operations”. Then uninstall eM Client and “Don’t delete the database on uninstall” when asked. Then redownload the same or later version of eM Client from the version history page and reinstall. Then finally reboot your computer to see if that fixes it.


I have tried the reinstall, no joy. I signed up for an account and added it. Same issue.

Mcafee firewall is off and i turned off net guard for em Client and outlook. I have the same issue now in outlook.

Other ideas on what could be blocking attachments?


Other ideas on what could be blocking attachments?

I would next suggest to eg: “try disabling all background non os tasks” on startup of your computer to see if there is something else automatically running on the bootup interfering with the mail client sending attachments.

If it then works, enable the background tasks one at a time and reboot after enabling each one till you find which task is the cause of the problem.

If disabling non os related background tasks makes no difference, then try restoring your os back to an earlier point / date in time “when it worked” using either System restore or Time machine depending if you have Windows or Mac.