Cannot send any messages

HELP. Suddenly I cannot send any messages. Have tried different senders and different recipients, but always the same result:

[SMTP]Cannot send message (Email recipient not accepted by the server.)

It is not a fault with the email server. I can send messages from a different PC using the same server.

Yes, it is probably not a fault with the server; but a fault with the email address/account you are sending to.

Your error says that the recipient is not accepted by the server. Sometimes there is more information so it would be more clear as to why, but in any case, the server doesn’t accept the address you are sending to.

Go to Menu > Settings > General and make sure that Show Local Folders is selected. Then go to the Local Folder Outbox and delete the message if it is there.

Thank you for replying, but I’m afraid that it hasn’t helped.

As I said in my posting I have tried sending from two different eM CLIENT accounts to numerous recipients that I have been sending to for years.
I checked Show Local Folders as you suggested and it is selected.

Also as I said, I can successfully send messages to the same recipients from Windows Live Mail, using the same mail server with no errors.

Any other ideas?

If you go to Menu > Operations, then look in the Log tab for any SMTP errors, there might be more information.

Here is what is in the what is in the Operations log after one attempt at sending myself a test message:

3:57:21 PM Don Crawford SMTP Connecting: To Don Crawford
3:57:30 PM Don Crawford [SMTP] MailClient.Storage.Application.OperationException: SMTP server doesn’t support authentication.
at MailClient.Protocols.Smtp.SmtpSendCommand.Authenticate(WorkerStatus status)
at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
EnqueuedStackTrace =
at MailClient.Protocols.Smtp.SmtpAccount.<>c__DisplayClass3_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Smtp.SmtpAccount.SendAsync(IEnumerable1 items, Action1 sentItem, Action`1 completed, CancellationToken cancellationToken)
at MailClient.Accounts.BindingAccountBase.SendInternal()
at MailClient.Accounts.BindingAccountBase.Send()
at MailClient.Accounts.AccountManager.SendInternal(IAccount account)
at MailClient.Accounts.AccountManager.Send(IAccount account)
at MailClient.UI.Forms.formMain.accountSend_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, WM msg, IntPtr wparam, IntPtr lparam)
at Interop.User32.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.Interop.Mso.IMsoComponentManager.FPushMessageLoop(UIntPtr dwComponentID, msoloop uReason, Void* pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(msoloop reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(msoloop reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(ApplicationContext context)
at MailClient.Program.<>c.b__173_1()
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor, Boolean wrapExceptions)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Delegate.DynamicInvoke(Object[] args)
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at MailClient.Common.UI.Forms.BaseForm.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, WM msg, IntPtr wparam, IntPtr lparam)
at Xilium.CefGlue.Interop.libcef.run_message_loop()
at MailClient.Program.Main(String[] args)
GUIStatus_Exception_Reported = True

Gary, in answer to your email, No I don’t have a Pro License. If the log I just posted doesn’t help, maybe I should get a license.

In eM Client, please go to Menu > Accounts.

Go to the SMTP tab for this account and make sure that you have one of the following combinations.
Select one combination, click on Save & Close, then restart eM Client and try send the message again.
If that doesn’t work, try the next combination etc.

Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

Tried all three suggestions. The first and third gave this error


The second of your suggestions gave the original error.

It may not help, but nothing that I am aware of has changed on my installation of eM CLIENT, which I have been using with no problems since May 2021.

If the account is setup as IMAP you can remove and re-add the account without any loss of data.

Go to Menu > Accounts and remove the account. Then click on the Add Account button, enter your email address in the Automatic Setup, and complete the wizard.

Forgive me for asking, but what would be the point of removing and re-installing the account? The same problem occurs with two different accounts. How could they both have been affected by the identical problem at the same time?

Also, should I leave the SMTP setting as the last of your suggestions, namely

Port 465 = Use SSL/TLS on special port (legacy)

I did not make a note of the original setting.

It could be that your provider now requires you to use an app password. In this case, entering the account password will give you the error as in your password required screenshot. You will need to check with them if an app password is required. Of course, it could also be that you just have the wrong password. Maybe you can reset the password on their web interface, and then try again.

But this is a different error to the server doesn’t support authentication one. That one could mean that the server no longer supports username/password authentication. Removing and re-adding the account will choose the best method that the server offers, and this may be oAuth, which is different to what you are currently using. But most likely it means that you have the wrong settings. That is why I gave the combinations to try.

But if you have the same issue with accounts on different servers, have you considered restarting your router?

Yes, you can leave the port set to 465, as many providers recommend that even though it is not an official SMTP port.

I’m sorry if I appear to have an answer to all your suggestions, but as I said previously, I can send messages using Windows Live Mail on this and on another computer using exactly the same email accounts and passwords and using the same server, with no problems. So, am I not correct in saying that the issue cannot be anything to do with the mail server?

URGENT Now suddenly I cannot receive emails, but no error message. Can you tell me if that could be caused by changing the SMTP setting? If so, how can I fix it?

I’m pleased to let you know that I have fixed the problem.

All I had to do was to go into the Diagnostics tab under my account and click on “Diagnose”. It initially came up with “Failed” under both POP3 and SMTP, so I clicked “Fix” and after cycling though numerous options it said “Fixed” for both. So now I can send and receive.

All’s well that ends well.