Cannot delete an email address from auto suggest when composing an email.

Couple of old email addresses that I know are not valid and cannot delete.  They always show up during the drop down when I compose an email.  They do not have a red x next to them and I already cleared out all email addresses through tools/settings/mail/compose.  When I right click on the address and go to edit contact it shows that the contact is in a folder called “Local Folders”.  I have no clue where to find that folder and to clear out it’s content.  Any help???

Hi there,

just had the same issue (sort of). Went to contacts, clicked all boxes I could fins, selected the invalid domains, deleted them. It actually worked.

Afterwards the deleted contacts don’t come up as suggestions again. Not the best of user experiences with all the decoy options that don’t do anything, but hey, it works :slight_smile:

with best regards


Glad it worked for you Jens. Frank’s contacts were saved in Local Folders, which he was not able to find. If you can’t see them, you can enable them in  Menu  >  Tools  >  Settings  >  General  >  Show Local Folders.

Another place auto-suggested addresses can be found is in the recipient history. You will find that in Menu > Tools > Settings > Mail > Compose > Recipients History.

Thank you for the help. That’s pretty many of distributed settings for the auto suggest function. Would be probably a good idea to have all of them on the compose page. I 've already cleared ou the recipients history, unfortunately this didn’t do the trick. The simple “If I click delete on the suggestion list it is gone (maybe with a confirmation dialogue)” is still best for the regular “this address is old/invalid/bollocks/painful” use case.

Recipients history is separate from Contacts. I guess that was a decision the developers made to hide it away like that. Some other email clients include the recipient history as a subset of contacts, which makes it much easier to manage as you only have to look in one direction to find them. :slight_smile: