Cannot accept outlook invitations

When I click “Accept” on a calendar invitation from an Outlook user it does not get added to my calendar. It does not give me any error message. I use a non-google email and google calendar.

If I accept a calendar invite from a Google user it works fine.

Can anyone help? Thanks.

That is because it was added to your Local Folder Calendar.

Go to the calendar section and tick the Local Folder Calendar.

image

If Local Folders are not visible, you can enable them in your settings.

If you want your Google Calendar to be the default Calendar for a non-Gmail address, you can specify that in your account settings. To do that open the settings for your non-Gmail account, then go to the Default Folders section and select the Google Calendar. Now when you receive an invite on your non-Gmail address, the event will automatically be added to the specified calendar.

image

Hope that makes sense. :wink:

Thank you for responding. I enabled local folders but there is nothing under my local folder calendar. I checked the account and my google calendar is specified under default folders / calendar as larrypra@gmail.com/larrypra@gmail.com/. I reselected just to be sure but the calendar name did not change. Do you have any other ideas?

The calendar name won’t change. It just means that when you receive an invitation sent to your non-Gmail email address, the event will be saved in the Google Calendar you just specified in your settings.

My google calendar was already selected as the default calendar for my email account.

Then you must have done that yourself previously.

Maybe do a search for the invitation. That should show you where it is.

I just accepted one and searched. It is not showing up anywhere. Are there any logs that would show me what happened or do you have any other ideas?

Oh, you withdrew you comment. No matter.

I sent an invitation from an Outlook.com account to a GMX address, and the event was saved in my Local Folders when I accepted it. Next I selected a Google calendar as the default for my GMX address, and configured it as I described above, and now the invites are being saved in my Google Calendar.

Sorry I can’t reproduce your situation, Larry.

I am using the latest version 8 beta available in the Release History, so maybe you can try that if not already using it.

Otherwise, out of ideas.

Thanks for trying Gary. Much appreciated.