Can’t activate the "catch-all alias" option on my IMAP+SMTP account


I have a setup with a custom IMAP server and a SMTP server.
I’m trying to activate the “catch-all alias” for this account, as I have a catch-all for the emails, however, despite clicking OK on the Alias dialog, then clicking on the “Save and close” button in the account dialog, everytime I come back the “catch-all alias” is unchecked.
Also if I try to answer to an email received on such alias, the from is not equal to the alias I received the mail on.

How can I check what’s going wrong ?

It means your server doesn’t support catchall aliases.

What should I change in the postfix and/or dovecot configuration to pass the checks.
I can’t seem to find documentation on what is required by emClient.

So any hint, if it’s possible to use this function with this setup ?