Can receive emails after pressing 'connect' but still cannot send emails

eMClient can’t verify identity of

This usually happens when the certificated on the domain is incorrectly registered. If you look at the popup it will say something like the name on the certificate does not match the domain you are connecting to.

You can select not to ask you again, and then connect, but that doesn’t really resolve the problem of the certificate being incorrect, as it could very well be another server pretending to be yours.

Please ask your email provider to look into this.

Or is this popup coming from your anti-virus application. If you have AVG/Avast, and it is mentioned in the popup, completely disable the anti-virus application and see if you still get this issue.

Thank you Gary but, as you say, the problem is still there.

Yes agree with @Gary needs the domain or server tech staff to look into that. Supanet support page below with all the contact support options.

I tried Supanet but they say it is an eMClient problem!

The certificate mentions Avast. I wonder if I should remove Avast?

The certificate mentions Avast. I wonder if I should remove Avast?

Yes you would need to either completely disable Avast or uninstall Avast (to test and reboot) without Avast running.

Both Avast and AVG are known to interfere with alot of email clients including eM Client. Even if you allow eM Client via these programs they can still give you issues. You don’t need them anyway if you have Windows 10 or 11 or the latest Mac OSX as they have these type of programs built-in.