Can not connect to smtp server

All of a sudden, after many months of use, for two days now I cannot send email. I get an error stating it could not connect to the server which could be caused by server unavailability or incorrect settings. I contacted the provider and they say they have no server problems. In the error message window I have chosen to attempt to fix the smtp connection but that fails.
I have tried all the settings as outlined on their page for Outlook:
https://help.suddenlink.com/knowledge/microsoft-outlook-set-your-suddenlink-email

I have tried changing my password with my provider and tried setting the smtp settings in em client to all 3 different ports. (When the diagnostic runs I see that it actually tries all 3 ports.) Is there a chance that there is something wrong with the server and they don’t know about it?

Any thing else I can try?

TIA,
CB

Wouldn’t you know it? After two days of not working, within minutes of posting here, it started working! Thanks anyway!!

Saturday 10 October 2020 :: 0752hrs (UTC +01:00)

Hi @cwbeas1

Microsoft have changed access, follow this link

https://support.emclient.com/index.php?/Knowledgebase/Article/View/87/0/why-is-my-outlookhotmailmsnlive-account-not-synchronizing-or-really-slow

¡Saludos desde la soleada España!

Skybat

emc_forum@compucall.com

Hola Skybat-¡Saludos desde el soleado oeste de Texas!

I’m just using a single computer for downloading messages so (AFAIK) I am using Pop3, not IMAP.
And FWIW, I only mentioned Outlook because my host (Suddenlink) didn’t seem to have any instructions for 3rd party apps like eM Client, which is what I use, not Outlook.

Thanks for taking the time to care!!

Adios,
CB