Can I stop full email addresses from appearing in "to" in email headers

When I sent emails using Outlook, I could have the email addresses in the “To” section of the email header not display, which I liked in order to preserve privacy for multiple-recipient emails. For example in em client, it always appears as “Joe B@email.com” instead of just “Joe B” in the “To” section.

In Contacts, is there a way to make em client just display the more anonymous name without the full email address when sending to multiple recipients?

EM Client provides the standard BCC field for these hidden “to” recipients. Tools/mai/compose menu to show the fields when creating a new mail.

eM falls short when it comes to basic stuff like this. I too am not thrilled with my contacts email addresses showing in replies and forwards. Only have eM for a short time but I’m considering dropping it.

  

Use the answer that Stephen Billard gave you about using the Bcc option to sent or forward your messages. The only thing I would add is that when I installed eM Client I had the turn on the option that allowed me to use the Bcc option. To turn on the Bcc option —Click on Menu then Tools then Settings then Mail then Compose and select Show the Cc and Bcc fields when composing. Using the Bcc field to send emails prevents any of the group you are sending to from seeing any information about the rest of the of the group, not even their name.

Of course the problem with Bcc is that if the email is or becomes part of an ongoing conversation, reply to all will not include those who are hidden. Just something to consider.

Thanks for the comments & suggestions. I’m still using emClient and find it a good (or even better) replacement for Outlook.