Can emClient be set as the Windows system default for MAPI ? (not IMAP!)

Hi - I often find it handy to send a Word (or Excel, etc.) document by email directly from within Word (I have Word 2010). Historically, I have used Thunderbird in this role, but I have switched my main email account to emClient Pro (part of the Softmaker Office 2012 Pro suite). I cannot see how to set emClient Pro as the default mail application for MAPI - either from within emClient or from within Windows 8 32-bit. Any help would be appreciated.

Hi, simply open eM Client - Tools - Settings - General and press the “Make default” button. If it will not help, open Control panel in Windows and set eM Client as default mail application.

Hi George,

Thanks for your suggestion. However, with Windows 8 Pro, that still doesn’t work for MAPI.

In the Windows 8 control panel, under “default programs,” one has to set the default programs separately for these two different aspects - one is the “MailTo” feature for clicking on “MailTo” links on webpages, and the other is the MAPI feature, for sending documents as attachments directly from within, say, Microsoft Word. Selecting eM Client for the MAPI function doesn’t work for me at all - but when I instead select Thunderbird for the MAPI function, it does work from within Microsoft Word (or Excel, etc.). I tried your approach from within the eM Client Pro 5, but it does not cause eM Client to start up for the MAPI function when I try to invoke it from within Microsoft Word.

I still like eM Client very much - it is my primary mail program now, but I still have to use Thunderbird for MAPI functioning.

It doesn’t work for Windows 7 also. 12 month ago and no solution!!!

It works for most people. In the cases which we diagnosed the most common cause for the broken MAPI was that the mapi32.dll file in Windows was replaced by 3rd-party application.

Thanks for your answer. I’ll test it.

I just tested eMClient again for MAPI. I used the Windows Default program setting window to make eMClient defaul for MAPI, and did a test from within Microsoft Word - telling it to send the document as an attachment to myself. When I did that, my backup mail program, Windows Live Mail started up and presented a mail composition window!

Thus, the system (windows 8.1, 32-bit) still won’t accept eMClient as default for MAPI, even when I set Windows up to choose eM Client.

This a not a BIG deal to me, only a minor nuisance, but I thought you should know.

With the original Windows-mapi32.dll file also, it does’nt work.

I have the same problem with MS software sending a file as an email attachment. I’m on windows 8.1 (Surface Pro 2) and I’ve set all the mail defaults to eM Client. Same problem as defined above. If it is a mapi32.dll problem, can you explain how to fix?

Thank you.

Hi - I HAVE indeed been able to set up emClient to be the system default for Windows MAPI for some months, now.  While continuing to use Windows 8.1 (with the upgrade from Microsoft some months ago), I managed to use the windows control panel to select emClient as the default program for the MAPI protocol (and I also used the emClient “settings-general” to set it as the default client).  emClient works like a charm to send documents to an email recipient directly from within Word, now.  I hope this information helps someone on this forum.  

Hi Christopher, do you have both .NET framework 2 and 4 installed on your Surface?

Thank you,

Does it also work for sending pictures via Send to - Mail recipient? Thanks.