Calender items not saving to GMAIL but to local folder despite setting under accounts

I have set my default calenders to point at google (although not sure whether I should be choosing “calendar” or

When I create a new calendar item it saves to the local drive by default

please, what have i done wrong??

for the same reason I can’t accept meeting invites from e.g. outlook since they save to my local folder whereas I need them to sync to google so I can then pull down the items to my phone.

please help me - I’ve missed two meetings this week as they didn’t ultimately end up on my phone!


Hi Nick, if you’re using a google account all you should need to do is to enter your email address and password into the automatic setup and all available services for your account should be setup automatically, including the Google Calendar. How did you setup the account?
Are you a pro license user or are you using the free license version (or demo/trial)?

Thank you,

thanks for the quick response. The problem is that I am not using the gmail account as my primary account. I am just using it as a means to sync my calender to my phone. So the primary account “Content Mill” receives meeting invites and I set new items in there. I want them all to sync to google so they then sync to my phone.

does that make sense?

Hi Nick, that’s unfortunately not possible to forward all invites to another mail account. Gmail invites are sent directly to the calendar.

Thank you for understanding,

ok so how do I get invites onto my phone if I am using EM client on my laptop?

Well if you’re getting the invites on your google account, just setup the google account on your phone as well.

Hope this helps,

that is the problem - they are not appearing on google since they save to the local folder when they come into the default account “Content Mill”. Same with new items. When I hit “new” it defaults to local folder despite setting default calender in “Content Mill” account to save to google calendar

NB it works if I manually change from “local” to ",gmail account. - what I don’t understand is why it is ignoring the default setting under accounts - see image above that is annotated

Hi again, this is a correct way to setup such thing actually, I’ve misunderstood the issue. However if you receive the invite in eM Client what happens after you accept it? This might cause issues with the account setup and you may receive an error “you’re neither attendee or an organizer of the event”.

Are the events saved in your local calendar?

This setup won’t be able to send invites from your phone/ accept invites from your phone though. Not really sure how to instruct you to setup such option.

Thank you,

I am not worried about from phone -> EM Client; only EM Client to phone:

I set the default calender folder to

yet when I go to file - new event

the default is google/calendar:

New event is added to the calendar folder you’re currently located in. The default calendar folder you have setup in the accounts window is setup for accepted invites.

Thank you,

but how do I get them both to save, by default, to the folder in the first of the two screenshots? At the moment they are saving to different calenders in gmail and only one is accessible on my phone. There is no sign of gmail/calendar events

When an invite is received by your account, by clicking accept you should have the event in the default gmail calendar shown on the first screenshot.
No events should be inserted into your ‘Calendar’ calendar on gmail by default. Only if you’ve clicked on the folder and the folder is active, new event will be added to this folder, but invites should be always saved into the default folder.

Hope this helps,

ok - so that is half of the battle solved - I shall wait to see when I next get an Outlook invite as to whether it works!

However that doesn’t solve the new events issue . By default it is doing what you say it shouldn’t do: “No events should be inserted into your ‘Calendar’ calendar on gmail by default.” This is exactly what is happening!

What you’ve suggested and posted a screenshot of is while you were located in the ‘Calendar’ and used the “new” event button. That way the event will be added to the current active calendar folder… which in your case was ‘Calendar’. If you’re having an issue where invite would be saved into this calendar, I’ll be happy to take a look at it.


thanks for your patience on this - I appreciate I don’t appear to be understanding something fundamental here!

It sounds like you are saying I can’t create a new diary item (want to avoid using the same word for different things) directly into my google calender: gmail/

I need to manually change this when I create the new diary entry. Is that correct? Is there somewhere else I should create the new diary entry from so that it doesn’t default to “gmail/calender” but to “gmail/”?

thanks again for your help on this

Nick, if you want to add a calendar item into gmail/ click on that calendar and press new.
Then you’ll be entering an entry into that calendar. But if you have the focus on the gmail/Calendar, the item will be added to this calendar instead.
You have to select the calendar you want to enter the entry in.

Also if you select a different calendar and add the calendar entry, you have the option to change the calendar in the event details (you’ve screenshot this option).

I’m not sure what we’re missing here, but the calendar entry is not default to the gmail/calendar folder, the event is added to this calendar only when you have the focus on the calendar (you’ve opened the calendar).

Is this any help?

Thank you,

ok i got it - brain is engaged today. You mean the different calenders on the left hand side of the screen - have now successfully tested. So provided the next invite i get from outllook goes into that same calender we are sorted. Thanks for your help - sorry it was like pulling teeth!

Great, keep me posted if you come across any other issues with the calendar or any other feature in eM Client, we’ll be happy to help.

Thank you,