Calendar invite not working

I am having major issues with this system. For whatever reason, my calendar invites are not being sent to the listed recipients. Also, the eM Client does not play nicely with Zoom meetings.

1 Like

Normally it is your calendar server that sends the invitation, so there could be an issue with the server.

But maybe you disabled sending of invitations, so neither eM Client nor the server will send them. You can change that back by going to Menu > Settings > Calendar > Invitations. Check that is set to always ask, or always send, and click on Save & Close.

Thx for the worthless tip. It was set to Always ask and your system never asked. Have you stopped to think it may be a bug in your software? Why is it that I pay for a license for something and it doesn’t work. And why would you ever have a setting as important as this one stop working without any sort of notification? This “sending” is like the primary purpose of scheduling a meeting, so why would it not be a fundamental function that is “fool-proof” to the user that the invitation actually made it to the intended recipient.

Well, with CalDAV the server normally sends the invitation without giving you the option to send or not send it. So with those servers you won’t be asked and the server will just send the invitation. If the participants are not getting the invitation, then the server is not sending them as it is supposed to do. You will need to ask the calendar provider for assistance.

With servers that do give the option, if you have set this to never send, then the server won’t send the invitations. So you will need to change the setting back to the default Always Ask.

If you can’t resolve it with your calendar provider, you can save the events in a different calendar. And if you create them in Local Folders, eM Client will send the invitations itself and the participants will get their invites.

My point is why would anyone ever set it to never send? What purpose does that serve? And no, I never set the setting – I just accepted the default that said to ask – which your system NEVER asked. So, I assumed it was sending. It was not until I began having people not show for meetings that I discovered the invites are not being sent. And why would any calendar system not confirm the invite was sent? This just seems like a basic fundamental function of a calendaring system and your response seems to indicate you are blaming Microsoft and Google because those are the only calendars I have. And I specifically purchased this software because you claim to integrate Google and Microsoft calendars only to find out your software can’t even do the basic function of sending an invite correctly. So, would you like to fix your software or continue to blame the servers of other providers? It appears you are now telling me I need to do a workaround and use my LOCAL calendar – I have no idea what you’re inferring here.

Telemetry and research shows that some users don’t want to send invitations, so the option is provided not to send them. As long as their server supports asking, then choosing to Never Send will mean invitations are not sent out.

The server says it will send them, and so that is the end of that. There is no function or standard for calendar protocols to query the server later to see if it has actually sent the message. The only way you will know if your provider has some issue, is if the participants don’t get their invitations.

Both Google and MS calendars support asking if you want to send, so you will get a popup asking if you have selected to Always Ask. If you choose to send the invite and the participants don’t get it, then that is a server issue and you will need to ask the calendar provider for assistance.

Yes, if you are not able to resolve this with your calendar provider, you can use your Local Folder calendars instead. eM Client sends the invitations itself for that calendar, so we can guarantee the invitation will be sent.

Your system NEVER produced a “pop up” asking if I want to send when the setting was clearly set to “ALWAYS ASK” – so, what’s your explanation for that failure? And I said that in my initial send. Again, you are not addressing the failure. You are giving me indications that you don’t believe your system is at fault and then suggesting a workaround.

1 Like

I have emClient installed on multiple devices. Out of curiosity by following this thread, I did check that setting on the computer I am using right now browsing the internet (not my work device), and I could see also the “Send Invitation” setting was set to “never send”. Same as the OP I did never change that setting, and so I am really interested why such an important setting is set to “do nothing” out of the box.

It’s not. The only way it can be set that way is if you change the option in Settings yourself, or when you are asked if you want to send the invite you select not to ask you again and choose No.

It is easy enough to check what the default settings are. Close eM Client and open Windows Explorer. Go to C:\Users\yourusername\AppData\Roaming. You may have to enable hidden items in Explorer to get there. Rename the \eM Client\ folder to something else and restart eM Client. That will start with a clean new database with all default settings. You will see that this is set to Always Ask. Close eM Client and go back to C:\Users\yourusername\AppData\Roaming\ in Windows Explorer. Delete the \eM Client\ folder and rename the other one back to \eM Client\ then restart eM Client to be back in your usual database.

1 Like

Why is it you can’t answer this question? I can go to my outlook client and schedule appointments all day long without any issue of my invitations making it to the intended attendee. Using eM client, no invitations are sent no matter what setting I use. If you can’t figure this out, then I want a full refund.

1 Like

My system was set to the default to ASK ALWAYS – however, the system NEVER asks. So, set it to send always – NEVER SENDS

I can verify that by default the “Allways Ask” calendar option “does bring up the popup” when you create the event to ask if you want to send the invite or not as per the below Gmail Calendar example event. The only time it normally doesn’t popup is if you have checked the option to “Don’t ask me again” as @Gary advised further up in his post.

Also i can verify that the recipient’s “do get the invitation” as per the email reply example below i got this morning where the recipient accepted the invitation i sent this morning.

So agree with @Gary that if you are sending the invitations and you are not getting any replies where you should be, then either “your server is not sending them for some reason”, or “you have some local database problem” and you need to create a new database to test as Gary also advised.

eM Client eM Client 9.2.2144 for Mac Gmail Calendar Invite example sent and received.

Thanks – I will be more than happy to demonstrate via a live Zoom/Teams how my system does not work as you indicate, yet I can use Outlook on the same system and invitations flow as designed. If it’s a configuration issue, then you’d think it would be solved by now as I have tried all known settings.

1 Like

I have the same unsatisfactory situation:

  • SOGo calendar is connected to em Client via CalDav. Synchronisation works in principle, but when I create a meeting request in the client, the participants do not receive an invitation and I am not asked whether an invitation should be sent.
  • If I create a meeting request directly on SOGo, the participants receive an invitation (if I confirm this when asked).
  • Same SOGo calendar connected to Vivaldi via CalDav: Participants receive an invitation (if I confirm this when asked).
  • Same SOGo calendar linked to Outlook via caldavsynchronizer: Participants receive an invitation.
  • Horde calendar connected to em Client via CalDav: Participants receive an invitation (if I confirm this when asked).
  • So the problem is not with the calendar server and not with a fundamentally incorrect setting in the em Client, but with the interface.

Is there already an idea for a solution from the em Client side?

Probably you disabled that option.

You can turn it back on as I said above. Here it is again: Menu > Settings > Calendar.

Then it is up to the calendar server to send the invitation.

Thanks for the quick response - but as I wrote above, the invitation works (on demand) in other CalDav calendars on the same client. The setting looks like this for me:

If the setting is on, then it is a server issue, which you will need to discuss with the calendar provider

I don’t believe that:

As I tried to explain above, the server sends invitations (on request) both when I create them directly in SOGo and when I link the same calendar in another mail client via CalDav (tested with Vivaldi and Outlook).

I probably didn’t express myself precisely enough - but the two standard answers from many simillar posts in the forum (“wrong setting in the em Client” or “calendar server can’t do it”) just don’t help.

Unfortunately there is no standard for the server to send a confirmation back that it has sent it, so if the server says it will send it, then that is as far as we can go. We don’t know if it does what it said it would do or not. Obviously it didn’t if the attendees did not get invites.

You have a Pro license, so open a support ticket with us, and we can show you in the logs as far as we can go. But as I said, we have no way to confirm if the server actually does what it says it will do, so that is something you will need to discuss with the calendar provider.

Thanks and good idea: I’ll take care of such a ticket (but probably not until next week). It would also be interesting to see the logs from the mail clients where communication with the calendar server works exactly as it should. But perhaps it would help to compare at least the logs of the working CalDav calendar on the client with those of the SOGo calendar.