Calendar Invitations


a few minutes ago i had the following issue, which concerns also invitations:

  1. An external person invites me to an appointment
  2. I get the invitation by mail, it looks like this:

  1. I click “Accept” and the other person gets an mail, that i’ve accepted the invitation
  2. Em Client doesn’t write this appointment to my calendar…why??

We use Caldav / Carddav (Sogo based on mailcow).
We also use the latest EM Client Version.
If we test that with internal users within our Mail System, the appointment is showed in our personals calendars.
Only if we get an external invitation, it will not be written to personal calendar.

We also tested the following:
If we use the Sogo Webmailer, it works!
If we use a Thunderbird with Caldav / Carddav, it works!! Thunderbird creates an entry in the calendar only with opening the mail, without accepting.

If you look the screenshot, you will see there a file-attachment “attachment.bin”.
If i save that on disk and rename this to “attachment.ics”, i’m able to open the file with double-click.
EM Client then open the follwing mask:

Why does EM Client name the attachment to “attachment.bin”?
Other Mail Client are showing this with another name with ending .ics.

And can you reproduce the issue, that external invitations, that are accepted, were not saved in personal calendar?


The event is created in the calendar associated with the email account the invitation was sent to. If it doesn’t have a calendar as part of the account, then the event is created in the Local Folders calendar instead.

It may be that your server parses the name like that, but we do display it as an ics anyway. The area marked in red is the ics file. And as you said when you click on it, it opens the file correctly.

What you can try is right-click in the message body and choose Properties > Repair > Repair. This will bypass what the server parses and download the message raw. Is there any difference?

If that doesn’t help and you have a Pro license, open a support ticket with us and we can look at the source code of the message you received to see if there is some issue there.

Hi Gary,

i activated the option to show local folders.
There i can see under “local folders / calendar” the entrys!
But how can i associate my mail-account with my caldav-folder?

In EM Client i have an imap-Account plus the Caldav- / Carddav-Account.
I want to use the Caldav-Account because all appointments should be synchronized.
Is there chance to change that?
I don’t want to display the local folders, because the users would get confused.

Go to Menu > Accounts and click on the General tab for your email account.

Scroll down to Default Folders, and click on the Select option for the Calendar.

Choose the calendar where you want invites sent to that address to be saved.

Click on Save & Close when done.

1 Like

Wow, perfect, that works :+1:t4: