Calendar colours *not* local calendars

Hi,

I’ve set up some remote calendars, pointing to my local NAS with a Baikal (caldav/cardav) server installation. This works pretty well, of course :wink:

Additionally, I’ve given each calendar a different colour. The calendar items in the various calendar views show the right colour - no problem at all.

It would, however, be handy if the colour is used on the navigation panel, left side, too, see image below. The local calendars are showing their colours, the remote ones unfortunately don’t.

Is there anything I can do to get this running?

cu,
Michael

Hi Michael, what version of eM Client are you currently using? The calendar colors should be shown automatically for all your account, unless this feature is not supported by your server.
Do the displayed calendar folders belong to the local NAS server account?

Thank you,
Paul.

Paul,

I’m using the latest available version of emClient, just ordered a few days ago :wink:

Perhaps the Baikal server does not use calendar colors, I guess that’s true, however I’ve used the calendar’s property page and selected a different colour for each of the remote calendars.

As already mentioned, the calender grid shows the correct colors, however, not on the navigation panel.

The calenders with checkboxes are stored on the local NAS running Baikal caldav/cardav server, those are missing the colours as you can see on the screenshot above.

The two calendars on the bottom of the screenshot are local ones and the colours is correctly shown.

cu,
Michael

Hi again Mike, are these delegated or shared folders for your account? Can you please make a screenshot of the folder tree including your account in the sidebar?
Can you please go to Tools > Settings > Advanced and turn on CalDAV logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. File > Work Offline (twice to return to Online mode).
    After the application finishes synchronizing your account, please go back to the advanced settings window and click on “send logs” and send the logs to mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

Hi Paul,

don’t know exactly what you mean with delegated or shared.

Anyway, those calendars in question are secured with a username and a password any everyone who knows the local URL to the Baikal server calendars and of course the login credentials can access them w/o any problems. This applies to emClient as well to Thunderbird with Lightning add-on and additional to any of our Android devices with a caldav sync app.

The screenshot you’ve asked for is already in the first posting unless I misunderstood your request. There is nothing more.

Logs for one of the the remote calendars are done and sent to the provided e-mail address.

May I ask you a bit different question than my initial one. In the screenshot below, you can see the properties of one of my remote calendars. The URL is pointing to the local NAS as before.

I’ve changed the colour of my calendar to red. The calendar items are painted with a red background in the calendar grid, perfect!

Now back to my initial question: Why isn’t there a red box in front of the calendar in the sidebar as can be seen in my very first screenshot on top? It simply missing whereas local calendars get this box.

Thanks,
Michael

Hi again Michael, your account setup is pointing directly to the calendar you’ve setup, for such accounts we unfortunately do not display the calendar color in the calendar folder tree, however you should be able to setup your account as a principal url of the user (you), which should list all these calendars.

Please setup a new account using the caldav url: 
http://192.168.6.96/baikal/cal.php/principals/Michael/

We’re considering adding a calendar color checkbox to the subfolder tree, however it might be included in future updates, no existing plan to adding the feature for several upcoming releases.

Hope this helps,
Paul.

Paul Thanks for this suggestion and indeed that helped and now the colour on the left side of the calendar entry is visible.

Btw, I did configure a similar URL with my contacts, too. This way I did not have to set up many carddav addressbooks but a single one :wink:

Thanks again!
Michael

Hi again, no problem, glad I could help, please let us know if you come across any other issues or questions about the application, we’ll be happy to help.

Thank you,
Paul.