Calendar bug leads to 25% CPU usage

Hi,

I have a problem with the calendar tab. When I minimize emClient to tray, I sometimes notice a high CPU utilization of emClient. When I open it up again, the calendar keeps running forward as fast as possible and I end up in 28xx or something. I also cannot stop the calendar running forward even if I try to use the “back one month”-button.

Any suggestions?

Hi,
can you provide a screenshot of Task Manager showing that eM Client is really causing this unexpected activity?

Thank you,
Paul.

Hi,

I added a photo of the problem:

Hi,
can you please download and run this tool while receiving a high CPU ussage? (http://www.emclient.com/tools/emstackdump.exe)

Send me the output to mcgregor@emclient.com with reference to this forum topic?
Thank you,
Paul.

You got mail

Do you have any more suggestions? I guess this happens after I put in my master password and do not open emclient. so if it is never opened, it runs through the calendar in background.

Hi, I’ve received the logs and am currently waiting for a response from the developers, not sure if I understand the scenario you just mentioned.

Are you running eM client in the background (e.g. closing it to tray?).

Thank you,
Paul.

Ah ok, thank you. I think it is something like this:

  1. Start emClient
  2. Wait some time
  3. Enter master password
    4a. emClient starts, but in tray so no window was visible
    or
    4b i see and minimize the emClient
  4. open emClient from tray -> calendar runs straight to infinity :slight_smile:

Hi, we could use some more data to find the solution for this. Do you think it would be possible export the events from your calendar to .ics format and send that to us by email as well, from the looks of the logs you’ve sent us it seems like something from your calendar might be causing the issue.

If you’re willing to share this information with us, can you please send it to mcgregor@emclient.com, again.

Thank you,
Paul.