Calendar 30min bumped up to 45min

When I add a 30 minute item to my calendar, it bumps it up 45 minutes and the shape is not rectangular but has a little square cut-out on left. So if I have a subsequent calendar item that starts immediately after the previous calendar item ends, the shapes overlap even though the scheduled time do not overlap.
How can I prevent the overhang and how can I make the calendar shape stay exactly within the schedule time frame? I tried changing the granularity from 30min to 15min and it didnt help.
Appreciate your advice, please help.
Thanks, Catherine

Default meeting duration? - menu/settings/calendar