CalDAV in combination with GMX only works partially

I’m using eM Client (6.0.21372.0) together with the e-mail provider GMX. Mail is working fine so far. CalDav is working only partially.

The things which are working:

  1. Creating an event on the GMX WebGUI is visible on the eM Client calendar
  2. Modifying an existing event which was created on the GMX WebGUI is working as well

The thing what is not working:

  1. Creating a new event on the eM Client and saving it then. I always get the following error:

My fist assumption was that this looks like a server error and thereofre I already had contact with the e-mail service provider. He gave me then the link to the help where I saw the full CalDAV address. Then I adjusted it again and tried it out but still the same error when creating a new event. After that I tried it out in Thunderbird. There it was working. Therefore it’s most likely that it’s on the eM Client side.
Let me know if you need additional logs from the eM Client or additional information so that you can trace down the problem.

Hi Maurus, this error can be thrown when there’s no access to the calendar, can you make a screenshot of your CalDAV account setup from Tools > Accounts? Based on the error it seems like you don’t have permission to write in the calendar.



I can see the entries.

So reading is working. I can modify the existing entries. Question is if that is a write operation or it’s handled in a different way.
But the other question is that it’s working on Thunderbird and here not? And because of that I would say that I do have write permission but probably Thunderbird and eM Client are handling new entries in a different way.

Here the requested screenshot:

Hi again Maurus, can you please navigate to Tools > Settings > Advanced and enable CalDAV logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    After the issue reoccurs, please go back to the advanced settings window and submit the logs to us using the “Send logs” button, please submit the logs to my email [email protected] with a reference link to this forum topic.

Thank you,

Reproduced the error and sent you the error logs as requested.

Do you have any update to this topic? I sent you the logs on the 8.2.2015 @ 18:36.

Hi, I’ve reported the issue to the developers of the application and submitted the received data for more information about your issue, however I have not heard back from the developers yet.


Thanks for the fast update. In that case I will wait till I get feedback from the developers.

Are there any news concerning this issue? Few days ago I installed eM Client Version 6.0.22344.0 and experience exactly the same problem with the CalDav Sync to gmx.
Regards Reto

Hello, can you please create some additional logging data as suggested above and submit the data to me for more information about this issue? Please submit the logging data by navigating to Tools > Settings > Advanced after you replicate the issue with logging enabled, send the message to my work mail [email protected] with a reference link to this forum topic.

However I’m afraid this is more likely a server issue.

Thank you,