calander not syncing with hosted exchange

My calander is not syncing with my hosted exchange calendar.  I can get my emails and contacts but for some reason my calander will not sync.

My Mail is syncing fine, but my calander seems to sync but does not update.

I think my calander is pointing to a local folder and not the hosted exchange calander

Any advice?

Hi Anthony, what version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? Are you seeing any errors thrown by the application? Are you using any security software on your computer, that may have disabled the applications ability to fetch your calendar data?

I have the exact same problem even with the newest version 6.0.22313.0

11:00:09 AM Online state: changed to online due to NetworkAvailability
11:00:09 AM zzz.net [POP3]  Connecting: To zzz.net
11:00:10 AM zzz.net [POP3]  Connected: To zzz.net
11:00:10 AM xxx.com [Exchange Web Services]  Synchronizing folder list
11:00:10 AM zzz.net [POP3]  Downloading messages: From zzz.net
11:00:10 AM zzz.net [POP3]  Disconnected: From zzz.net
11:00:10 AM zzz.net [POP3]  Disconnected: Done
11:00:11 AM xxx.com [Exchange Web Services]  Synchronizing folder list
11:00:12 AM xxx.com [Exchange Web Services]  Synchronizing folder list
11:00:12 AM xxx.com [Exchange Web Services]  Synchronizing folder ‘xxx.com/Inbox/
11:00:13 AM xxx.com [Exchange Web Services]  Synchronizing folder ‘xxx.com/Calendar/
11:00:24 AM xxx.com [Exchange Web Services]  MailExceptions.ConnectionException: Operation is not valid due to the current state of the object. —> System.InvalidOperationException: Operation is not valid due to the current state of the object.
11:00:24 AM    at System.Linq.Enumerable.Futures1.<.cctor>b__da()<br>11:00:24 AM at System.Linq.Enumerable.FirstImpl[TSource](IEnumerable1 source, Func1 empty)<br>11:00:24 AM at System.Linq.Enumerable.First[TSource](IEnumerable1 source)
11:00:24 AM at MailClient.Protocols.Exchange.ExchangeCalendarSynchronizer.d__c.MoveNext()
11:00:24 AM at System.Collections.Generic.List1.InsertRange(Int32 index, IEnumerable1 collection)
11:00:24 AM at System.Collections.Generic.List1.AddRange(IEnumerable1 collection)
11:00:24 AM at MailClient.Protocols.Exchange.ExchangeItemSynchronizer2.ConvertApplicationDataAndSkipUnparsable(ExchangeService service, Item item, CancellationToken cancellationToken)<br>11:00:24 AM at MailClient.Protocols.Exchange.ExchangeItemSynchronizer2.d__b.MoveNext()
11:00:24 AM at System.Linq.Enumerable.d__313.MoveNext()<br>11:00:24 AM at System.Collections.Generic.List1…ctor(IEnumerable1 collection)<br>11:00:24 AM at System.Linq.Enumerable.ToList[TSource](IEnumerable1 source)
11:00:24 AM at System.Linq.Enumerable.ToArray[TSource](IEnumerable1 source)<br>11:00:24 AM at MailClient.Protocols.Common.ScheduleItemSynchronizeContext1.StoreItems(SynchronizationType type, IEnumerable1 newItems)<br>11:00:24 AM at MailClient.Protocols.Common.ItemSynchronizeContext2.Synchronize[T](SynchronizationType synchronizationType, IEnumerable1 items, Func2 getUniqueId, Func3 hasChanged, Func2 isDeleted, Func2 convertItems, Action2 updateItem)
11:00:24 AM at MailClient.Protocols.Exchange.ExchangeItemSynchronizer2.Synchronize(IItemSynchronizeContext1 synchronizeContext, Folder folder, CancellationToken cancellationToken)
11:00:24 AM at MailClient.Protocols.Common.ItemSynchronizer`2.<>c DisplayClass30.<>c DisplayClass35.b__2c(WorkerStatus status, CancellationToken cancellationToken)
11:00:24 AM at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)
11:00:24 AM — End of inner exception stack trace —
11:00:24 AM at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)
11:00:24 AM at MailClient.Commands.Command.Process(WorkerStatus status)
</.cctor>

I have same or similar problem. Version of the eM Client is 6.0.22328.0. and Google calendar not syncing. In previous version was  (one week ago) working sometime (usually only if I restarted eM) and one moth ago was everything super ok.

Where is a problem now, please? Whats going on?

Haw can find a history of a previous versions of eM? 

Peter, this is an unrelated problem to the Topic, the above problem is regarding an Exchange account.

You can however both try to update your eM Client to this release, which includes a number of minor fixes regarding the latest release of eM Client, 6.0.22336.0 .

Joe, please check if the issue persists as it includes a couple of Exchange fixes as well.

Peter, if the issue persists, please create another topic on the community support.

Paul,

It’s been persisting all but the first week I started using emclient half a year ago. I clicked the repair button and it erased everything that synced the first week and filled in some calendar appointments after that. It hasn’t worked since. What does my log tell you I need to do?

Hello Joe, sorry about the belated reply, can you please make sure you’re running the latest available release, 6.0.22344.0 and check if the issue persists? If you’re still experiencing the problem, can you please navigate to Tools > Settings > Advanced and enable Exchange Web Services logging for the problematic account?

Save the settings and restart the application, once the error reoccurs, restart the application and please go back to the advanced settings window to submit the logs to us using the “Send logs” button.

Please include a reference link to this forum topic for more information about the problem. We might also need to exchange some private information, so it may be better to get the discussion of the public community support.

Thank you.

I’ve done so. No reply or fix

Hello, I have not received any logging data, I’ve forgot to include my work mail here, did you submit the data to support@emclient.com ? If not, please submit the data to my work mail, mcgregor@emclient.com with a reference link to the forum topic.

Thank you,