Bug - wrong language being translated to

For some reason in the past week the app is choosing to translate into some slavic language rather than English which is set in the System.

How do I fix this please?

miércoles 22 junio 2022 :: 1249hrs (UTC +01:00)

Hey @NomadStays

You say English is set as the default language, is this at:
Menu ->Settings ->General ->Language ->English
ALSO check the setting:
Menu ->Settings ->Mail ->Translation ->Check the settings here
Unless yo have a specific reason confirm all are set to ASK & Language of Application

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks @skybat - confirming those settings are correct in my app but the app still translates to something quite different

miércoles 22 junio 2022 :: 1438hrs (UTC +01:00)

Hey @NomadStays

OK, what language in the email is being translated into ‘slavic’ language?
Is there a small or large amount of foreign language being translated.
Normally there is a single line message just above the main message window saying:

XYZ language detected. Do you want to translate it now or never.

What is the language detected?

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Can you change the spell-check language to something else, then Save & Close.
Then go back and change it back to English.

Anyone have any solutions?

You’ll notice the Subject is written in French and the translation is definitely not English as the settings are set to.

Tried that - no change - still reverts to something not english

jueves 23 junio 2022 :: 1101hrs (UTC +01:00)

Hey @NomadStays

OK, the language is Croation.
You have posted the example as an image.
Is this how you received it or is it a screen grab?
If an image it will NOT be automatically translated.
If it is text email it to me direct and I will do it for you.

The first line of the image reads:
Here is the latest Travelport presentation, which allows agents

I do not know why you are receiving this error, sorry.
However, I also had a similar problem when auto-translation thought Spanish was French - I simply ignored the information message - I have a Spanish OS, keyboard etc., and use eMC in both Spanish & English, that varies with whatever I am doing. I did query the issue and I was told translation is an algorithm based on the amount of text, that did not explain why there was incorrect identification. I did not bother any further as I am multi-lingual plus some of the translations are, shall we say suspect.

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

jueves 23 junio 2022 :: 1131hrs (UTC +01:00)

Hey @NomadStays

I have some free time so here is a translation of the text I can see,
from top to bottom it reads:

Welcome new tools that allow you to focus on what matters most: Your Customers.

Here is the latest Travelport presentation which allows agents to save time and maximize
productivity through self-service.

BETTER
AUTOMATION
WORK FLOW

Currently many agencies do not have enough staff and they have to deal with a large number
of travel changes. Our new self-service tools eliminate more and (no more text)

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks @Skybat. FYI - the emails comes through as normal html emails, not images - that’s just my screen grab for the purposes of posting in the support forum.

Of course I can copy and paste the docs into various translators.

The translate function inside the app is still broken. So its a real pain to do all the open, copy, open browser, find translate, past, read . . .

especially when the marketed solution is ‘click the button’.

I operate a global company so get lots of foreign language emails. The in-app translation was one of the reasons we chose EM when swapping out of Outlook last month.

Now I just need the big fixed. Any idea how we can lodge this directly with the company?

jueves 23 junio 2022 :: 2134hrs (UTC +01:00)

Hey @NomadStays

I should have asked, does this happen with all languages?
I do not know if it is the HTML that is causing the issue, just a thought.
What happens if you send yourself a simple message with say a single line message?
Try this if you can send, copy & paste of the message language that has the issue.
I do not use translators if possible, my company, www.compucall.com has multi-lingual colleagues that I can ask if I do not know myself (I am retired but I still have access) I have also collected languages for years).
I think that the eMC translator is based on BING, so maybe this needs changing.
One of the responders to your post @Gary - you will see he has ‘Leader’ after his avatar showing he is an employee of eMC, maybe message him.
I do not know if you are using a trial or Pro version of eMC, I am not sure if a trial gives you VIP support, Pro does here: https://support.emclient.com

Sorry I do not know what else to suggest.

Yes, I know you have an interesting/exciting looking company - I looked you up.

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks @skybat. Adding @Gary

Bing Translator seems to be working correctly using your test idea.

EM not though as you can see from these pics.

Just checked Windows language settings and there’s no mention of Croatian or any Slavic languages.

Us simple folk from Australia only really learn 1 language as a general rule. :slight_smile: so its not unusual to get everything translated in ENG even when we’re dealing globally.

I can’t recall if we’ve bought the Pro Plan yet - we did decide (pre problems) we’d get it as the new email client for the company though .

viernes 24 junio 2022 :: 1349hrs (UTC +01:00)

Hey Mark…

I know what you mean, my daughter is married to one of you ‘simple folk’, they used to live in Wanaka, NZ for the winter sports now in Broome, WA, they tell me they now prefer sailing, (bit of a quantum leap but you would understand this); she frequently needs to translate OZ speak for me, for instance your sellotape & thongs have different names and meanings here (condones - durex, thongs - lingerie)
I’ve concluded that the issue is that you’re all the wrong way up and suffer from either XXX or XXXX on the brain.

Seriously, I understand, yes the BING online translator gives an accurate translation but if I am correct about its integration into eMC it’s translation is useless by identifying French as Croation: ‘U redu - pokusajmo s ovum porukom’ which has been translated as if the original French was: D’accord - essayez ce message (this is the wrong tense and becomes an imperative - OK, Try this message!) so even the translation to Croation is wrong.
Anyway none of this matters, what does matter is the initial language identification.

I am sorry that can not help you with this and suggest you either message @Gary or contact eMC VIP support.

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Still looking for a solution to my ‘Croatian Problem’

@Gary - is there a help desk contact that can be used?

Even the pricing is now converted into Kuna!

In Menu > Settings > General > Language, change the language to something else and click on Apply. Then change it back to English, and click on Apply.

English is always at the top of the list (1) and the Apply button is always in the same position (2) so you can get back easily.

Restart eM Client and see what the translation does.

If it is still the same, can you give a screenshot of Menu > Settings > General > Spell-Checker

sábado 25 junio 2022 :: 1046hrs (UTC +01:00)

Hey @NomadStays

I saw your post to @Gary - are you using a VPN?
If so turn it off and try again.
The currency shown is: Czech koruna
Not Croatian Kuna

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I think I’ve solved it. :slight_smile:

There is a separate Translations section (as well as a Language section). In that Translations section somehow a setting has made to ‘translate all French into Croatian’ instead of the default ‘Language of Application’ as we set on all other languages.

(Translations section under Mail not General.)

When I went down the Translations Language list I saw the problem setting.

Goodness knows how this setting was made but it’s now set back to default and my French emails are reading correctly.

Anyway, by using a VPN I got the price also displayed in USD and have bought a few licences.

Thanks @skybat for your help. I really wasn’t looking forward to going back to Outlook. :slight_smile:

domingo 26 junio 2022 :: 0949hrs (UTC +01:00)

Hey @NomadStays

Sorry, I should have thought to point you to that setting that I was aware of, and it did not occur to me to ask you to check as I do not bother with it myself, I just read emails the way they arrive. I am just an enthusiastic user offering help to other users, not an employee.
Anyway great you have it sorted.

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.