Bug: Changing email subject

When changing an email’s subject, it fails under certain conditions. In particular, it fails when using square brackets at the beginning of the subject. Example:

  1. Email has subject of Test
  2. Edit subject to [My] Test
  3. Hit Enter and respond Yes to the confirmation dialog.
  4. Email subject does not save, reverts to Test


  1. Email has subject of Test
  2. Edit subject to [My Test (only use left square bracket)
  3. Hit Enter and respond Yes to the confirmation dialog.
  4. Email subject changes to [My Test (as expected)
  5. Edit subject again to add the right square bracket, i.e. [My] Test
  6. Subject changes to [My] Test (as expected)

Once edited successfully by using the workaround, removing the phrase with the square brackets, i.e. [My] also fails unless you remove one bracket at a time.

I am not able to reproduce this.

On which server is the message saved?

I didn’t think of server side issues. In my case, the email is on Dreamhost, where my domains and email live.

I just tried changing a subject on my gmail account and the behavior is even worse. It creates another email with the modified subject - and the new email is blank (nothing at all shows in the message window) and it can’t be deleted. :frowning_face:


p.s The new email that can’t be deleted does not appear in the gmail web interface, only in EMC.

p.p.s: Regarding the email that can’t be deleted, I closed EMC, put a check_db.txt file in the database directory to force a database check. It said Resolved 21 problems and the phantom email is no longer showing. That’s good…

I guess I’ll try to avoid the Changing Subject feature. I love the idea because sometimes people put non-informative subjects in their email, but the feature doesn’t seem to work that well.

I tried to reproduce this on IceWarp and my personal IMAP account with GMX. It works as expected.

On Gmail, my message just disappeared for a second, and re-appeared with the changed subject as I specified. I guess that was just a sync taking place.

BTW, for future use, instead of adding files to the database directory, just close eM Client and run this command: "C:\Program Files (x86)\eM Client\MailClient.exe" /dbrepair


Thanks @Gary - I’ll continue to monitor. I enabled IMAP logging for my Dreamhost account. I find where it’s pushing the changed message properties to the server, but I see no errors in the log. Maybe DH’s implementation has some problems.

Yes does sound like “Server specific IMAP related” issue. I also cannot reproduce this issue on Gmail - IMAP, Live - IMAP or My local ISP IMAP account.