Baikal CalDAV/CardDAV account doesn't work while using https (ssl)

I am running Baikal (http://baikal-server.com) on my Synology NAS and I am trying to sync my CalDAV and CardDAV accounts with EM Client. In order to make this connection as safe as possible, I use a HTTPS connection (SSL) in combination with a real SSL certificate on my Synology NAS. When I setup my account I don’t receive any errors, but my CalDAV and CardDAV accounts simply don’t show under the calendar/contact tab of EM client.

I have tried multiple URLs and I even used the specific HTTPS port 443 in the URL. But it makes no difference. When I use HTTP (no SSL) in the URL, I receive an error in EM Client that the connection failed.

These URLs did I use while setting up CalDAV:

https://MYSYNO/baikal/cal.php/calenda…
https://MYSYNO:443/baikal/cal.php/cal…
https://MYSYNO/baikal/cal.php/calenda…

I use the first URL with Bynari Webdav collaborator in Outlook 2010 and with Davdroid on Android, and that works just fine.

Looking at the CalDAV log of EM client, I just see 1 line:

10:26:30.821|00B| C: OptionsCommand https://MYSYNO:443/baikal/cal.php/cal…

Maybe EM client doesn’t support HTTPS/SSL?

Hi,
can you please send us logs from Fiddler? (http://www.telerik.com/download/fiddler),
when you install the tool, go to Tools > Fiddler Options > HTTPS and check the decrypt HTTPS option and save the setting.

You should be seeing all the HTTPS traffic from eM Client, please send the logs to mcgregor@emclient.com

Thank you,
Paul.

Hi Paul,

In what kind of file extension (.zas or .bat) do you want the log, because there are many options in the export menu?

Also I want to point out that after I enabled the decrypt HTTPS option and accepted a connection with the Fiddler certificate (DO_NOT_TRUST_FiddlerRoot) in EM client, I actually could see my Baikal CalDAV and CardDAV accounts in EM client. And there was also a lot of traffic activity in Fiddler.

Disabling Fiddler including the Fiddler certificate, stopped the synchronization of my CalDAV and CardDAV account in EM client. So maybe the problem is related to the SSL certificate.

Hi,
ok that’s an interesting information, doesn’t really matter which format.
However, based on these information… we could also use the Network Communication logs from our application (Tools > Settings > Advanced > Network communication), check the checkbox, save the settings and restart the application, again when the issue occurs, go back to the Advanced settings window and click on send logs also ass my email as a copy and you can add the fiddler logs into that email as well or send it in a second email.

Thank you,
Paul.

Hi Paul,

Did you receive my email with the logs?

Hi, yes I did, I’ve consulted them with the developers and they’re currently looking into it.

Thank you for your patience,
Paul.

Hello Paul,

Is there any progress?

Hi, sorry for the delay, I urged your issue and hopefully I’ll get back to you with an answer soon, sorry it’s taking so long.

Thank you,
Paul.

I am seeing the same problem.  Any progress with this.

I am having the same problem using Radicale server. Does the fact that this hasn’t been answered in two years mean that emclient will not support SSL connections for caldav?

Hello Wild,
since this is an old thread and you are using different server, it is more likely that the error might be of different nature.
Please set up CalDAV logging in Tools>Settings>Advanced.
Restart eM Client.
Try to resynchronize your Calendar (right-click>Repair).

Also copy and save the Log from Tools>Operations>Log window, please.

Go back to Advanced settings, click ‘Send logs’ but change the recipient to rust@emclient.com and add a link to this forum thread in the body of the message.

Regards,
Olivia