Backup does not create zip files so how to restore?

I’m trying to restore from a previous backup however I have no zip files within the folder. Having checked again, I did a backup from a new clean installation. Once again no zip files are created. How can I then restore? I’ve tried using import but then I get the message “the selected directory doesnt contain eM Client data files or the data files were created with too old version of eM client.” So then I tried doing a backup using V8 and trying to IMPORT from that data (as still no zip files) but I get the same message.

Make a backup using Menu > Backup.
Immediately go to Menu > Operations and see the progress. If it fails, there should be an error.
Typically this will be insufficient disk space. If that is the case, no more backups can be made until you free up some space. Look in the backup directory and iIf there are incomplete files, delete them as they will be using space.

Many thanks for a reply. This last backup actually created a zip file. That has never happened before (even this morning). I have over 400 gb disk space so that was never really going to cause a problem.

The previous file structure looks like this

Does this give you any clue? (I do realise the files are dated 2021 but its ok. Its some old email I wanted to retrieve)

Now put the zip file in …\Documents\eM Client.
Start eM Client and got to Menu > Settings > General > Backup. It should have …\Documents\eM Client\ as the backup folder. If not, change it.
Click on Save & Close.
Go to Menu > File > Restore.
If there is more than one backup zip file in that folder, you will be given a choice of which to use, otherwise, after a confirmation that this will replace all the existing data, the restore will begin.

That’s all well and good but this zip
File was made from a new install of em client so doesn’t contain any emails as yet. (I was just testing the backup procedure). I’m
Trying to retrieve older emails from
Previous backups which didn’t produce any zip files but files as per the screenshot above.

Your screenshot is a zip file - you have just opened it.
The file is backup_202108191722.zip

So place that file in …\Documents\eM Client\ and try the restore again.

thanks for your patience. So the screenshot isn’t a zip file as it is (it is not in the extracted view). It probably originally was a zip file that I have unzipped. So. I zipped it again and placed it back in the emclient folder as you instructed, where the new backup sits that was made a week ago. After choosing file, restore EM Client only gives me the option of using the new backup. I tried to navigate to the folder also, but it only shows the new backup, not the older backup I just rezipped. I even tried renaming the newer backup to xyz and renaming the OLD backup (which i want to use) to the exact same name as the new backup it insists on using. Then tried again, using file, restore, - EM Client did not even recognise there is a zip file in the folder. Only the newer xyz.zip file. Agh !! Could it be because the backup was made using an older version of EM Client?

I restored my laptop last summer 2021 and I successfully restored EM Client so I’m not sure what the problem is.

Is there an older version of EM client I could download to try instead?

As an update to my comment below, I uninstalled EM Client. I found an old *msi file (2021) and installed it. However same problem. It will not recognise the file that I zipped.

I am 99% sure that this folder (in the screenshot) was NEVER ZIPPED to start with. If It was, when i copied it over to my backups I would have renamed the folder to something useful (as I’m very organised) plus Its pointless to unzip and just increase file storage space when its not needed.

Yeah, looking at your screenshot again, I see that may not be the original zip file. Certain files that are in a backup are not there, so zipping to a backup file again will not work.

With eM Client closed, copy the complete contents of the backup-202108191722 folder to C:\Users\yourusername\AppData\Roaming\eM Client. You may have to enable hidden items in Explorer to get there.

Then restart eM Client.

Already have hidden items checked so thats OK. Copied the whole folder as you instructed. After restarting I now get “database verification and repairing failed” - please contact the support team. You’ve been very kind but I don’t think this is going to work. Think I’ll just have to start using Hotmail.

That is part of the issue with just copying the database like that. It is not guaranteed to work, and some items may be missing. That is why we keep the backup safely inside a zip file.

What are the error details from the database verification?
Some of them can be manually resolved.

here’s what I get

Microsoft.Data.Sqlite.SqliteException (0x80004005): SQLite Error 11: ‘malformed database schema (idx_MailItems_folderAndDownloadState) - no such table: main.MailItems’.
at Microsoft.Data.Sqlite.SqliteException.ThrowExceptionForRC(Int32 rc, sqlite3 db)
at Microsoft.Data.Sqlite.SqliteCommand.PrepareAndEnumerateStatements(Stopwatch timer)+MoveNext()
at Microsoft.Data.Sqlite.SqliteCommand.GetStatements(Stopwatch timer)+MoveNext()
at Microsoft.Data.Sqlite.SqliteDataReader.NextResult()
at Microsoft.Data.Sqlite.SqliteCommand.ExecuteReader(CommandBehavior behavior)
at Microsoft.Data.Sqlite.SqliteCommand.ExecuteReader()
at Microsoft.Data.Sqlite.SqliteCommand.ExecuteNonQuery()
at MailClient.Storage.Data.DataStore.GetConnectionInternal(String relativeName, Boolean privateConnection)
at MailClient.DbRepair.CorruptionChecker.CheckCorruption(RepairOptions repairOptions, CancellationToken token)
at MailClient.DbRepair.CheckingProcess.Check(CancellationToken token)
Data:
databaseFile: Archive\mail_index.dat

does that help? If you cant help further then I understand