Attached image files visible in body of email

Attached image files are visible below the main body text of emails both when composing and reading emails.

This is not the case in most other email clients, images are only visible in the main body of the email if they were inserted, not if they are attached.

Attachments should only be visible if actually opened.

This is surely a bug?

Actually, this is a feature - attached images are displayed at the bottom of the screen under the email.

Ok, thanks for the reply.

I’ve now found it documented in the Help Contents under Reading Emails as follows:

Automatic Resizing of Images

If you receive an image attached to your email it will be automatically displayed in the bottom of the email preview. There is a smart utility that automatically and simultaneously resizes the attached image as you resize the window of the email preview. If you want to display the image in its original size but still keep the email preview window arbitrarily resized, then click on the arrow symbol which can be found in the left upper corner of the image as you can see in the picture.

Actually quite a useful feature.

Displaying the images at the bottom of the email preview is clutter I don’t need. The feature would be useful for me only if it could be turned off. I want to know what my recipient will see, and I don’t know if they see the image, too, or just the files in the attachment tray. I prefer programs that adapt to me, rather than programs that force me to do it their way (i.e. Windows 7). Please consider making this forced image view an option rather than a requirement. Thanks.

Typical programmer calls a bug a “feature.”  It is NOT a feature if you don’t like it.  Get rid of it or at least make it optional so you can shut it off.

ditto…really very annoying “feature”

Agree, at least five the user the option.
I copy image files in explorer, then past these in an email, to be attachments, not to fill the screen.
Please fix.

The option is already there.

If you want them to be attachments, use Insert > File
If you want them in the body, use Insert > Image

Here we are, a year later . .

I inserted an image file (using Insert>File) and the image displayed inline when I checked the message in the ‘Sent’ folder. I am still waiting for the email to arrive.

Like Gerard, I see this feature as a bug, and a serious one, surely.

I have just done another test. It seems that ‘Insert’ is the same as ‘Attach’. Image files do not attach, they just display inline.

A poor show!

April 2019, still not fixed.  Very annoying see “attached” images showing inline in sent messages.  Very seriously considering saying good bye to emClient on this basis alone.

Hello Joe,

We’re sorry to hear that but as George stated above, this was developed as a feature, therefore it’s not a bug. However, I’ll add your vote to the feature request to create disable option so it can be considered while developing the next versions.


Why do you developer folks consider this a feature?  Typically developers call things that they oversee or botch up as features.  Especially when they make no logical sense.