ATT.Net POP3 Server Log-In Issue

I just migrated my email from Thunderbird to eM Client earlier today. My base email server is att.net. While I have the SMTP working properly to send emails I cannot log in to the att.net POP3 inbound server to download incoming emails. I have double checked my eM Client settings at the site below and am using inbound.att.net for the server address and Port 995 as recommended. ( https://www.att.com/esupport/article.html#!/email-support/KM1010523?gsi=8eprto)
I set up a new security key as recommended by att.net which I am using as the password.

But it won’t log in. Below is the diagnostic log from startup.  Any help would be appreciated.

8:50:11 PM Online state: changed to online due to NetworkAvailability 
8:50:11 PM john.diebel@sbcglobal.net [POP3]  Connecting: To john.diebel@sbcglobal.net
8:50:41 PM john.diebel@sbcglobal.net [POP3]  MailClient.Accounts.SocketException: Connection failed due to the following reason: 
8:50:41 PM     “Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”
8:50:41 PM    at MailClient.Protocols.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
8:50:41 PM    at MailClient.Protocols.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
8:50:41 PM    at MailClient.Commands.Command.Process(WorkerStatus status)

Hello,

This error is stating that the server didn’t respond so please check with the server support what might be the fix. You can also try the IMAP settings to see if it’s working and if your credentials are correct.

Russel