Assigning Tasks uses my personal, not business email


I am trying to assign tasks to my colleagues but by default it sends via personal email.

How to change that if possible? 

It will send from whichever email account you have set as default.

Go to Menu > Tools > Accounts, and change the default account to your business one by clicking on the star icon.

Thanks very much. I do think the option to have different task profiles would be better. 

Just checked something:

If your task list is an online one, like Google Calendar, the invitation will be sent from that account. So if you have 2 Google Calendars setup in eM Client, irrespective of what your default email account is, the invite will be sent from the account in which you save the task.

Local tasks will be sent from the default email account.

Good to know, I prefer to keep things like calendars locally.