Appointments created by emClient do not reflect Daylight Saving

I have my Gmail account synced with emClient and my iPhone. When I create an appointment in emClient and sync it to my Gmail Calendar and my iPhone calendar, the appointment appears 1 hour later than it should. I believe this is because it is not correctly accounting for Daylight Saving. If I create an appointment in May (after Daylight Saving ends) it all works correctly.

I am running emClient v6.0.19714 on a PC with Windows 7 Pro 64-bit that is fully updated with all patches and service packs and is part of a Windows domain. Timezone is set to GMT+10 (Melbourne, Australia) and the PC knows Daylight Saving is active.

I have checked both Primary and Secondary domain controllers and both are set to GMT+10 and both know Daylight Saving is active. Both are fully up to date with patches and service packs.

Emails in emClient are displaying with the correct date and timestamp - only Calendar appointments are affected.

If I create the appointment in Gmail or on my iPhone then when it syncs to emClient it appears one hour earlier than it should.

The only workaround I have found is to individually set each appointment in emClient to use GMT+11 but this is a real pain and does not work for recurring appointments that span the Daylight Saving boundary.

Is there a fix available for this problem?

Thanks,
Toby

Hi, please contact me on galis@emclient.com together with this topic’s url in subject.

Jan

Hi. I am also in Australia (Adelaide GMT+930) and am having similar problems to above.

In particular. Incoming emailed meeting requests (from Outlook/Exchange users) appear in EM an hour early. Appts created in EM appear 1 hour late in Google Calendar. Appts created in Google appear in EM one hour early

Setup same as Toby (updated win7 64 Pro) except time zone different by 30 mins. All clocks and daylight saving settings correct.

Tim Waterhouse

This problem has been reported by myself and others and is becoming a real pain. Interestingly, the people complaining appear to be from areas where DST is in force and syncing with gmail calendar. I suspect a lot more users will find this problem when their area switches to DST.

Agreed - I make appointments on desktop and on mobile devices and accept email ones - it is making a horrific mess of my calendar!
Tim

Hi, update on this issue. We are able to help people on Southern hemisphere, unfortunately not to those from northern one.
so who is living there contact me on galis@emclient.com with this topic’s url in subject.

rest of users please send me GData logs to same email address.

Jan

Sorry John, Is there a fix on this yet? From what it sounds, you guys don’t have a fix for it yet and are just gathering logs to get to the root of the problem (which i think is a calDAV issue…

Hi there is a fix to this in newest version 6.0.19489.0

Jan

Hi there,

I using v6.019714.0 on a Windows 8.1 64-bit operating system and having the same issues described above by other users.

In my calendar app on Samsung S4 phone the appointment times are correct. However, when viewing/creating events within eM Client application, all events appear one hour early. i.e. 6pm appointment on my phone shows as a 5pm appointment in eM Client.

Like others I suspect this is due to eM Client not adjusting for daylight savings.

This is a seriously annoying issue and I am thinking of switching to another application and deleting eM Client if this doesn’t get fixed soon.

It seems as that the issue was raised over a month ago by Toby Dods but still has not been addressed.

John Galis - would you be able to advise on current progress on resolving this issue?

If you need further information please let me know yizhi.lin2@gmail.com

Best,
David

Hi just to clarify, I have downloaded the latest update and am now using v6.0.19681 of eM Client. However, the problem still prevails despite release notes on your website that the problem was fixed in v6.0.19825.

Your help is much appreciated.

Best,
David

I will need your GData logs, go to tools - settings - advanced, check GData under your account, apply and restart eM Client.
Simulate steps that leads to your issue and after that use “send logs…” to galis@emclient.com together with this topic’s URL in subject.

Then you can turn logging off.

Jan