Application Not Found - Windows 10

I just installed eM Client ver 6.0.24928.0 on my laptop running Windows 10 ver 1511. Every thing works fine until I try to open a url from an email. When I do I get the Application Not Found error. I checked and Chrome is my default browser when looking in Settings\System\Default Apps.

I then checked Control Panel\Default Programs\Set your default Programs and I selected All for Chrome. I noticed that Internet Explorer still has several associations that it will not allow me to change. I’m not sure if one of these needs to be changed or not though.

Then I checked Control Panel\Default Programs\Set Associations. I believe the Protocols section would be relevant here, correct? It will not allow me to change anything currently associated with Internet Explorer.

Is there something I’m missing? It should just work right?

Hello Mark,
is this an eM Client or Windows error message? eM Client should just use your default browser for opening internet links.
Could you screenshot the error message and also include the number of your eM Client version from Help>About section?


Not sure if it’s a Windows or eM error but here are the screenshots.

Hello Mark,
that is definitelly a Windows error message. Looking around for this issue, I found that it tends to happen even with Microsofts’ own mail apps.
“This message can appear if the default browser is not set, or the http protocol association is incorrect.”
When you choose Chrome from the list, does it say that ‘This program has all its defaults’? I know you checked them, but maybe try re-setting it to IE and then back to Chrome?
If this does not help, I’m afraid you might have to contact Microsoft support.


Thanks for the help Olivia.  I guess it’s a Microsoft issue then.  I guess it wont get resolved then unfortunately.

Dear all,

I’m not sure if this issue has already been solved but I had the same problem and I could solve it easily by reinstalling Google Chrome and setting it back to default browser.

Hopefully this comment will help someone.


Wow, i just had this problem and tried what Marvin said and it worked!   Not a lot of traffic on this topic, but if you get the application not found error. it worked !  Woot…