Apple Mountain Lion Server integration

I have a new ML server set up serving a mixed network with Mail, Contacts, Calendar and Chat. Up till finding your product I had just about given up on full access to these services for my windows users. I successfully set up an IMAP mail account but got stuck finding the proper syntax to connect Chat (Jabber) and Contacts/Calendar (CalDav and WebDav). I also need to know if they are different depending on if connecting locally via my LAN or remotely via the www?

Thanks

Hi,
if you use our autodiscover, all the services should be configured automatically. If you want to configure them separately, use following URLs:
CalDAV: http://[domain]:8008/calendars/users/…
CardDAV: http://[domain]:8008/addressbooks/use…
Jabber: use your standard username and password.
Hope it helps you.

For some reason, the autodiscover did not configure chat, calendar or contacts. All these services are running and available to my Mac users. Looking at my Mac users account settings, they appear to be using different ports (8443 instead of 8008 for Contacts) that what you provided above. Attempting to use 8443 in eM Client was unsuccessful as well.

Has your Auto configure been tested with Apple server 10.8.4?

What eventually worked using SSL on my server (OSX 10.8.4) was to:
Add a New Account
Choose Contacts
Choose CardDAV
Fill in the Account address URL as follows:
https://[domain]:8843/addresbooks/where [domain] is my full DNS record for my server (example: server.xxx.com).
Fill in the User Name and Password fields as normally required.

Although Apple indicates they use port 8443 for Calendar, I got both Contacts and Calendar using this one account setting.

Also, I’m not sure why the Autodiscover feature did not work. And when selecting the mail account and the Diagnostics tab, only IMAP and SMTP are shown for diagnostics. CalDAV, CardDAV and jabber are not available to test or log.

Bottom line, I got everything to connect. all that is left to do is to test, test, test.
Thanks for your help.https://discourse.emclient.com/emclient/to…#

Hi,
I am glad you got it working. We have tested autodiscover with multiple Apple servers including 10.8.4 and everything works well so I cannot tell you why it does not work on your side - we will investigate it further.

I am encountering another issue with my setup. Some of my em Client installs are failing to produce Contacts and Calendars with the same settings.
There are no Errors reported, just an operation that never completes.
The Operations tab indicates the following:
[accountname]: Synchronizing subfolders
[CalDAV / CardDAV] For folder [accountname]/public/

The sync never times out nor finishes and as a result, no contacts or calendars are available.

I am configuring all CalDAV / CardDav accounts exactly the same
https://[domain]:8843/addresbooks/ where [domain] is my full DNS record for my server (example: server.xxx.com).

What ever it is seems to follow some setting on the computer as I have tried to configure a user that work perfectly on a different PC and ended up in the same limbo. I have a suspicion it may have something to do with the security certificate, but the other PC’s with accounts that worked seem to be exactly the same other than they work. All PC’s are the same make and same configuration.

Hi,
sorry for the delayed reply. Send us your full CalDAV log at support@emclient.com please. It will help us to find the cause of the problem. Thank you.

Logs have been sent.

i tried this using 8843 but never worked for me. I am using Server version 3 on mavericks. i entered https://mydomain:8843/addressbooks/us…

please help on this

Try using https://mydomain:8843/addressbooks/us… as the URL.

can you try using ht*ps instead, i can’t see the full line as it is hyper-linked. i tried ht*ps://mydomain:8843/addressbooks/users/user
i also tried 8800. those both ports are opened on my router. if i type this link on my browser, i can’t seem to go past /addressbooks/ “access forbidden” . my iphone and Mac both however sync perfectly with my server.

Ah yeah here is the line - ht*ps://mydomain:8843/addressbooks/users/username/

Do the same for calendars just change addressbooks to calendars

i tried that, but it did not work. I am not sure what to do, all other devices work. it feels that my server is not granting permissions to non-Apple hardware.

We have 10.8.5 server, and that address works for us. You can also try changing 8843 to 8443

Since it works on your iPhone can you go into the account on your iPhone and click on calendar then account then advanced settings.
Mine shows Use SSL on, port 443, the account url should start with h*tps://domain/principals/__uids__/stringoflettersandnumbers
Is that what your’s shows?

yes, that is exactly what both my mac and iphone says!! (8443) (although my router (Apple) is pre configured by the server to allow 8843 for both contact and calendar. (and i also believe 8800 for contact and 8008 for calendar), so do you think i should add open or add 8443 too)??

Yes open 8443 and give it a try.

The syntax: h*tps://[Domain]:8843/addressbooks/users/[User]/ does indeed work for my ML server. I hope this remains the same when I update to Apple Server 3.0.

P.S. the syntax: h*tps://[Domain]:8843/calendars/users/[User]/ is also needed for the calendar account.

it is working now, but i realized that it does not sync all the information. i.e. only 2 phone numbers and one or two emails. So many information is missing.
thanks

Hi,

it should sync everything, have you tried clicking on “Work” or “Home” button and changing it to anything else? These buttons are clickable and are meant to server as dropdown list.

with regards
Jan