Apple mail no mails receiving after 7 hours

Hi,
I installed the APP today and checked the IMAP settings for my apple account.
I get periodically a red triangle then it goes away for a long time. when I manually request get mail… It sometimes comes up but not always.
Apart from the welcome email , No email has been downloaded since the account opened. We have received several emails since.

Tested the account and it comes up as all OK on the account advance page.

Frustrated…

If you go to Menu > Operations > Log tab, are there any IMAP errors?

Hi Gary,

Yes this is the error log for this morning:
09:55:56 shkmedical@me.com [IMAP] MailClient.Accounts.ConnectionException: No server response within 30 second timeout. —> System.IO.IOException: No server response within 30 second timeout.
at MailClient.Imap.Base.Connection.ConnectAsync (System.Func`2[T,TResult] getStream, System.Threading.CancellationToken cancellationToken) [0x0048b] in <5384b7f5218945e5b08b5a8ebcdec584>:0
at MailClient.Protocols.Imap.ConnectionPoolEntry.ConnectInternalAsync (System.Threading.CancellationToken cancellationToken) [0x002c6] in <0ac04f1a8fff42658d2b2322934344ab>:0

I still get the wrong port after testing the connection under accounts. It should be port 993 but get 143 whe the error shows up.

Go to Menu > Accounts and select the IMAP tab for your email account.

Make sure the port is set to 993 and the security policy is Use SSL/TLS on special port (legacy). Click on Save & Close.

Restart eM Client and see if there is any difference.

Please open the menu Settings->Advanced->Logging and check “IMAP” under the problematic account. Restart eM Client, try to simulate the issue and send us the logs using the same logging settings window at wilson@emclient.com. Then I will be able to advise you further. Thank you.